Configure Error: Parallel version - removed option --enable-mpi  [SOLVED]

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit 8 builds.
For a video explanation on how to build Abinit 7.x for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.
Post Reply
getsruthil
Posts: 3
Joined: Sun Jul 19, 2020 7:31 pm

Configure Error: Parallel version - removed option --enable-mpi  [SOLVED]

Post by getsruthil » Sun Jul 19, 2020 8:34 pm

I have been trying to install abinit-9.0.4 on my Ubuntu 20.04 PC for parallel execution. For the same, I have followed the instructions given in the video http://www.youtube.com/watch?v=DppLQ-KQA68. The options for configuring was given in an input file given below.

Code: Select all

prefix="/usr/local"
enable_mpi="yes"
enable_mpi_io="yes"
with_mpi_prefix="/usr"
with_trio_flavor="netcdf+etsf_io"
with_netcdf_incs="-I/usr/include"
#with_netcdf_libs="-L/usr/lib -lnetcdf -lnetcdff"
with_netcdf_libs="-L/usr/lib/x86_64-linux-gnu -lnetcdf -lnetcdff"
with_fft_flavor="fftw3"
with_fft_incs="-I/usr/include/"
with_fft_libs="-L/usr/lib/x86-64-linux-gnu/ -lfftw3 -lfftw3f"
with_linalg_flavor="atlas"
with_linalg_libs="-L/usr/lib/x86_64-linux-gnu -llapack -lf77blas -lcblas -latlas"
#with_dft_flavor="atompaw+libxc"
with_dft_flavor="atompaw+bigdft+libxc+wannier90"
enable_gw_dpc="yes"
All the paths given in the config file have been checked for its correctness. Unfortunately, the configuration failed throwing an error
* removed option --enable-mpi. >>> use --with-mpi instead. error: removed option --enable-mpi has been used
.

I have been struggling to get it fixed by digging the threads in the forum, but to no avail. Any help on this would be appreciated. [Attachment: Config.log]
Attachments
config.log
(40.36 KiB) Downloaded 18 times

User avatar
jbeuken
Posts: 353
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: Configure Error: Parallel version - removed option --enable-mpi

Post by jbeuken » Mon Jul 20, 2020 10:56 am

Hi,

the youtube video is very old and not applicable with abinit 9..x version

As an attachment, a beta version of a document explaining
the instatllation on Ubuntu 19 but which is adapted for Ubuntu 20.

jmb
Attachments
README-Ubuntu.pdf
(94.28 KiB) Downloaded 63 times
------
Jean-Michel Beuken
Computer Scientist

ebousquet
Posts: 449
Joined: Tue Apr 19, 2011 11:13 am
Location: University of Liege, Belgium

Re: Configure Error: Parallel version - removed option --enable-mpi

Post by ebousquet » Wed Jul 29, 2020 10:43 am

Here is a possible example of installation of Abinit on Ubuntu 20 (it might not be the most optimized one but it works fine):

Installation of compilers/libraries:
- Compilers:

Code: Select all

sudo apt install -y g++ gfortran 
- MPI:

Code: Select all

sudo apt install -y openmpi-bin libopenmpi-dev
- Mathematical libraries (not sure how optimize they are):

Code: Select all

sudo apt install -y libblas-dev liblapack-dev 
This can be added if used:

Code: Select all

sudo apt install  fftw3-dev libscalapack-mpi-dev
- Mandatory Libxc, hdf5, netcdf (if you install with apt, each time there will have an update of these libraries, you might have to re-install Abinit for proper version linking... Otherwise follows what Jean-Michel mentioned with the fallbacks):

Code: Select all

sudo apt install -y libxc-dev libnetcdff-dev
- Depending on your need you can complete with:

Code: Select all

sudo apt install build-essential
Then once this is installed I could compile Abinit 9.x with the following config.ac9:

Code: Select all

enable_avx_safe_mode="yes"
with_mpi="/usr"
enable_mpi_io="yes"
LINALG_LIBS="-L/usr/lib/ -llapack -lblas"
with_libxc="yes"
LIBXC_CPPFLAGS="-I/usr/include"
LIBXC_FCFLAGS="-I/usr/include"
with_hdf5="/usr"
with_netcdf="yes"
NETCDF_CPPFLAGS="-I/usr/include/"
NETCDF_FCFLAGS="-I/usr/include/"
NETCDF_LIBS="-L/usr/lib/x86_64-linux-gnu -L/usr/lib/x86_64-linux-gnu/hdf5/serial -lnetcdf -lhdf5_hl -lhdf5 -lpthread -lsz -lz -ldl -lm -lcurl"
with_netcdf_fortran="/usr/include"
NETCDF_FORTRAN_LIBS="-L/usr/lib -lnetcdff -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-z,now -lnetcdf -lnetcdf"
Jean-Michel, do you have comments on this minimal set for installing on Ubuntu such that we can maybe converge to a stable example? We could check how to make netcdf in parallel?

Best wishes,
Eric

getsruthil
Posts: 3
Joined: Sun Jul 19, 2020 7:31 pm

Re: Configure Error: Parallel version - removed option --enable-mpi

Post by getsruthil » Fri Jul 31, 2020 9:45 pm

Thank you for all the responses.
With all the initial set ups and the minimal configure script the configuration went really well. Log is attached herewith for your reference.

I am trying to install abinit 9.x parallel version in an ubuntu 20.04 with 6 cores (12 threads). To do this i have applied the command make -j6 (as prompted at the end of compilation). However, it did not succeeded while throwing the following error:
make[5]: *** No rule to make target 'm_optim_dumper.F90', needed by 'm_optim_dumper.o'. Stop.
make[5]: *** Waiting for unfinished jobs....
../../../../../shared/common/src/14_hidewrite/m_io_tools.F90:1095:0:

1095 | iomsg = trim(msg)//ch10//"Runtime error message: "//trim(iomsg)



I am not able figure out what does this error. Any help would be appreciated.
Attachments
config.dump
(5.78 KiB) Downloaded 17 times
config.log
(177.6 KiB) Downloaded 14 times
Last edited by getsruthil on Mon Aug 03, 2020 11:15 am, edited 1 time in total.

User avatar
jbeuken
Posts: 353
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: Configure Error: Parallel version - removed option --enable-mpi

Post by jbeuken » Mon Aug 03, 2020 10:27 am

Hi,

I noticed that during the minimum ( or standard ) installation of Ubuntu 19 or 20, the python cmd is not "defined".
python3 is installed by default, but the link "python" to "python3" is not made .
However, during configure, a python script is executed with :

Code: Select all

#!/usr/bin/env python
one way to solve the problem is to make a symbolic link

Code: Select all

cd /usr/bin
ln -s python3 python
same workaround with python2
------
Jean-Michel Beuken
Computer Scientist

getsruthil
Posts: 3
Joined: Sun Jul 19, 2020 7:31 pm

Re: Configure Error: Parallel version - removed option --enable-mpi

Post by getsruthil » Mon Aug 03, 2020 11:46 am

Thank you very much dear moderators.
Your suggestions and fixes helped me to install abinit parallel version in my Ubuntu 20.04 pc with the setup given in the installation guide. 8-) :D :)

dprai
Posts: 1
Joined: Sun Oct 18, 2020 9:05 am

Re: Configure Error: Parallel version - removed option --enable-mpi

Post by dprai » Sun Oct 18, 2020 11:08 am

Dear Abinit users

I alos encountered this error while installing abinit9.2.1

================================
codvsn = ABINIT_VERSION
1
Error: Symbol ‘abinit_version’ at (1) has no IMPLICIT type
Makefile:1281: recipe for target 'm_sigtk.o' failed
make[3]: *** [m_sigtk.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory '/home/dprai/Software-Installed/ABINIT/abinit-9.2.1/src/67_common'
Makefile:1228: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/home/dprai/Software-Installed/ABINIT/abinit-9.2.1/src'
Makefile:1444: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/dprai/Software-Installed/ABINIT/abinit-9.2.1'
=========================
This is my configuration settings
./configure
with_mpi="/usr"
enable_mpi_io="yes"
LINALG_LIBS="-L/usr/lib/ -llapack -lblas"
with_libxc="yes"
LIBXC_CPPFLAGS="-I/usr/include"
LIBXC_FCFLAGS="-I/usr/include"
with_hdf5="/usr"
with_netcdf="yes"
NETCDF_CPPFLAGS="-I/usr/include/"
NETCDF_FCFLAGS="-I/usr/include/"
NETCDF_LIBS="-L/usr/lib/x86_64-linux-gnu -L/usr/lib/x86_64-linux-gnu/hdf5/serial -lnetcdf -lhdf5_hl -lhdf5 -lpthread -lsz -lz -ldl -lm -lcurl"
with_netcdf_fortran="/usr/include"
NETCDF_FORTRAN_LIBS="-L/usr/lib -lnetcdff -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-z,now -lnetcdf -lnetcdf"
with_libpsml="/usr/local"
with_xmlf90="/usr/local"
with_libxml2="yes"
with_wannier90="yes"
WANNIER90_LIBS="-L/home/dprai/Software-Installed/wannier90-3.1.0 -lwannier"

Please kindly help me in solving this problem.

User avatar
jbeuken
Posts: 353
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: Configure Error: Parallel version - removed option --enable-mpi

Post by jbeuken » Sun Oct 18, 2020 8:54 pm

Hi,
need more infos...

the output of ./configure

jmb
------
Jean-Michel Beuken
Computer Scientist

Post Reply