error while executing make for abinit-9.0.2

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit 8 builds.
For a video explanation on how to build Abinit 7.x for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.
Post Reply
saikrishna
Posts: 15
Joined: Fri Jun 21, 2019 12:11 pm

error while executing make for abinit-9.0.2

Post by saikrishna » Sat May 02, 2020 7:05 pm

Dear All Abinit users,
I have installed all mandatory libraries for abinit-9.0.2 and I have configured it. I executed the following command for configure:

./configure with_libxc=/home/sai/abinit-9.0.2/fallbacks/install/gnu/9.3/libxc/4.2.3/ with_hdf5=/home/sai/abinit-9.0.2/fallbacks/install/gnu/9.3/hdf5/1.10.6/ with_netcdf=/home/sai/abinit-9.0.2/fallbacks/install/gnu/9.3/netcdf4/4.4.1.1/ with_netcdf_fortran=/home/sai/abinit-9.0.2/fallbacks/install/gnu/9.3/netcdf4_fortran/4.4.4/ with_linalg=/home/sai/abinit-9.0.2/fallbacks/install/gnu/9.3/linalg/abinit_6.10/ FC=gfortran

And the result was the following

Core build parameters
---------------------

* C compiler : gnu version 9.3
* Fortran compiler : gnu version 9.3
* architecture : unknown unknown (64 bits)
* debugging : basic
* optimizations : standard

* OpenMP enabled : no (collapse: ignored)
* MPI enabled : no (flavor: none)
* MPI in-place : no
* MPI-IO enabled : no
* GPU enabled : no (flavor: none)

* LibXML2 enabled : no
* HDF5 enabled : yes (MPI support: no)
* NetCDF enabled : yes (MPI support: unknown)
* NetCDF-F enabled : yes (MPI support: unknown)

* FFT flavor : goedecker (libs: auto-detected)
* LINALG flavor : none (libs: ignored)

* Build workflow : monolith

0 deprecated options have been used:.

Configuration complete.
You may now type "make" to build Abinit.
(or "make -j<n>", where <n> is the number of available processors)

Since the above result came, I proceeded to execute the make command.

I issued the make command, then the following error popped up,

make[5]: *** No rule to make target 'm_optim_dumper.F90', needed by 'm_optim_dumper.o'. Stop.
make[5]: Leaving directory '/home/sai/abinit-9.0.2/shared/common/src/14_hidewrite'
make[4]: *** [Makefile:1183: all-recursive] Error 1
make[4]: Leaving directory '/home/sai/abinit-9.0.2/shared/common/src'
make[3]: *** [Makefile:1156: all-recursive] Error 1
make[3]: Leaving directory '/home/sai/abinit-9.0.2/shared/common'
make[2]: *** [Makefile:1157: all-recursive] Error 1
make[2]: Leaving directory '/home/sai/abinit-9.0.2/shared'
make[1]: *** [Makefile:1435: all-recursive] Error 1
make[1]: Leaving directory '/home/sai/abinit-9.0.2'
make: *** [Makefile:1364: all] Error 2

Can anyone help me with this? I really appreciate immediate help as it is urgent. My system's configuration is

Intel B960 processor 2.2 GHz, 2 GB RAM, 500 HDD and pentium processor, dual core. The OS is Ubuntu-20.04.

Thanks in advance,
Sai Krishna N.

User avatar
jbeuken
Posts: 350
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: error while executing make for abinit-9.0.2

Post by jbeuken » Mon May 04, 2020 10:06 pm

Hi,

Code: Select all

LINALG flavor : none (libs: ignored)
no linalg : strange...

can you send me the ouput of :

Code: Select all

cat fallbacks/build-abinit-fallbacks.sh
A+
------
Jean-Michel Beuken
Computer Scientist

ycyer
Posts: 1
Joined: Sat May 09, 2020 2:16 pm

Re: error while executing make for abinit-9.0.2

Post by ycyer » Sat May 09, 2020 2:29 pm

jbeuken wrote:
Mon May 04, 2020 10:06 pm
Hi,

Code: Select all

LINALG flavor : none (libs: ignored)
no linalg : strange...

can you send me the ouput of :

Code: Select all

cat fallbacks/build-abinit-fallbacks.sh
A+



Hi~~~ I met the same error,and here is my output after I run the upper code :

[ycyer@ycyer abinit-9.0.2]$ cat fallbacks/build-abinit-fallbacks.sh
#!/bin/bash

# Init
fallbacks_prefix="/home/ycyer/Opt/abinit-9.0.2/fallbacks/install/gnu/8.3"

# Find and Unpack tarball
cd /home/ycyer/Opt/abinit-9.0.2/fallbacks
tarfile=$(ls *.tar.gz)
source=$PWD/${tarfile%.tar.gz}
if [ ! -d "$source" ]; then
mkdir -p $source && tar -xzf $tarfile -C $source --strip-components=1
fi
cd $source
make clean

# Configure
./configure \
--prefix="${fallbacks_prefix}" \
--with-tardir="${HOME}/.abinit/tarballs" \
--with-linalg-incs=" -I/home/ycyer/Opt/abinit-9.0.2/fallbacks/install/gnu/8.3/linalg/abinit_6.10//include" \
--with-linalg-libs="-L/home/ycyer/Opt/abinit-9.0.2/fallbacks/install/gnu/8.3/linalg/abinit_6.10//lib " \
--with-fc-vendor="gnu" \
--with-fc-version="8.3" \
--disable-bigdft \
--disable-atompaw \
--disable-wannier90 \
--disable-xmlf90 --disable-libpsml \
CC="gcc" \
CXX="g++" \
FC="gfortran"

make -j 4 install
rc=`echo $?`

if test "$rc" = "0"; then
printf "$(tput bold)----------------------------------------------------------------------$(tput sgr0)\n\n"
echo "The fallbacks are now ready to use."; \


How could I solve this problem?
Thanks for advance!!!

User avatar
jbeuken
Posts: 350
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: error while executing make for abinit-9.0.2

Post by jbeuken » Fri May 15, 2020 5:34 pm

Code: Select all

--with-linalg-incs=" -I/home/ycyer/Opt/abinit-9.0.2/fallbacks/install/gnu/8.3/linalg/abinit_6.10//include" \
--with-linalg-libs="-L/home/ycyer/Opt/abinit-9.0.2/fallbacks/install/gnu/8.3/linalg/abinit_6.10//lib " \
it can obviously never work!
the library "linalg" ( lapack, openblas, atlas, mkl ) must already exist on the system !

for example, in the abinit ac file, here is the part dedicated to the numerical library :

Code: Select all

with_linalg_flavor="netlib"
LINALG_LIBS="-L/usr/lib64 -llapack -lblas"
there are packages under OS ( Centos : yum search lapack, Ubuntu : apt search lapack )
------
Jean-Michel Beuken
Computer Scientist

sathyasheela
Posts: 2
Joined: Thu Feb 09, 2012 9:59 pm

Re: error while executing make for abinit-9.0.2

Post by sathyasheela » Wed Oct 21, 2020 9:49 am

Dear Sir,
I encounter the same problem when I give make.
I am using abinit-9.0.4, my build system is x86_64-unknown-linux-gnu, C compiler : gnu version 9.3
* Fortran compiler : gfortran, ubuntu 20.04.

make[5]: *** No rule to make target 'm_optim_dumper.F90', needed by 'm_optim_dumper.o'. Stop.
make[5]: Leaving directory '/home/rvitm/sathya/abinit-9.0.4/shared/common/src/14_hidewrite'
make[4]: *** [Makefile:1172: all-recursive] Error 1
make[4]: Leaving directory '/home/rvitm/sathya/abinit-9.0.4/shared/common/src'
make[3]: *** [Makefile:1145: all-recursive] Error 1
make[3]: Leaving directory '/home/rvitm/sathya/abinit-9.0.4/shared/common'
make[2]: *** [Makefile:1146: all-recursive] Error 1
make[2]: Leaving directory '/home/rvitm/sathya/abinit-9.0.4/shared'
make[1]: *** [Makefile:1449: all-recursive] Error 1
make[1]: Leaving directory '/home/rvitm/sathya/abinit-9.0.4'
make: *** [Makefile:1373: all] Error 2

I gave the command
cat fallbacks/build-abinit-fallbacks.sh and this is what i get


#!/bin/bash

# Init
fallbacks_prefix="/home/rvitm/sathya/abinit-9.0.4/fallbacks/install_fb/gnu/9.3"

# Find and Unpack tarball
tarfile=`basename $(ls /home/rvitm/sathya/abinit-9.0.4/fallbacks/*.tar.gz)`
source=${tarfile%.tar.gz}

mkdir -p $source && tar -xzf /home/rvitm/sathya/abinit-9.0.4/fallbacks/$tarfile -C $source --strip-components=1
cd $source

# Configure
./configure \
--prefix="${fallbacks_prefix}" \
--with-tardir="${HOME}/.abinit/tarballs" \
--with-linalg-incs="" \
--with-linalg-libs="-L/usr/lib64 -llapack -lblas" \
--with-fc-vendor="gnu" \
--with-fc-version="9.3" \
--disable-bigdft \
--disable-atompaw \
--disable-wannier90 \
--disable-xmlf90 --disable-libpsml \
LIBS_NETCDF4_FORTRAN="-ldl -lm -lz" \
CC="gcc" \
CXX="g++" \
FC="gfortran"

make -j 4 install
rc=`echo $?`

if test "$rc" = "0"; then
printf "$(tput bold)----------------------------------------------------------------------$(tput sgr0)\n\n"
echo "The fallbacks are now ready to use."; \
echo "You can link these fallbacks with Abinit by copying the following options to your ac9 file.";

list_of_fbks=( libxc hdf5 netcdf4 netcdf4_fortran linalg xmlf90 libpsml wannier90 )
for i in "${list_of_fbks[@]}"; do
if test "`${fallbacks_prefix}/bin/abinit-fallbacks-config --enabled ${i}`" = "yes"; then
Prefix=`${fallbacks_prefix}/bin/abinit-fallbacks-config --libs ${i}`
printf "\n$(tput bold)"
echo "with_${i}=${Prefix}" | sed '-e s/-L//; s/\/lib //; s/netcdf4/netcdf/; s/-l.*$//'
printf "$(tput sgr0)"
fi
done
printf "\n"
else
printf "We have detected a problem while generating fallbacks : contact Abinit's team\n"
fi

exit

Can you please help me with this error.

Post Reply