Potential problem with Lu JTH v1.1

Moderators: torrent, jzwanzig

Post Reply
andrewshyichuk
Posts: 1
Joined: Wed May 06, 2020 1:17 pm

Potential problem with Lu JTH v1.1

Post by andrewshyichuk » Wed May 06, 2020 7:53 pm

Dear Users,

I've tried to generate a PAW potential using this dataset: https://www.abinit.org/ATOMICDATA/071-lu/index.html, atompaw 4.1.0.6 and LDA.
It results in an error:
Eigenvalues of overlap operator (in the basis of projectors):
...
The overlap operator has at leat one negative eigenvalue!
It might be not positive definite...
Program is stopping.
I've contacted Prof. Natalie Holzwarth about it, and there seems to be no easy fix.
(The one we tried failed dramatically).

At the very least, the v1.1 dataset is questionable as is and I thus recomment using JTH v1 Lu from, e.g. http://www.pseudo-dojo.org, which works fine (at least, with Quantum Espresso).

Also note that the "bad" dataset results in a pseudopotential file using some older versions of atompaw - the overlap operator check was added only recently.
Thus, the fact that older atompaw produces the potential does not mean the potential is good.

Best regards.
Andrew.

ebousquet
Posts: 469
Joined: Tue Apr 19, 2011 11:13 am
Location: University of Liege, Belgium

Re: Potential problem with Lu JTH v1.1

Post by ebousquet » Thu Jun 04, 2020 4:07 pm

Dear Andrew,
Thank you for your report.
In any case, the user should always check convergence and validity of the pseudo used, even in the case of a often used pseudo, it is possible that it fails in the specific conditions of your system.
Best wishes,
Eric

Post Reply