How to use the PAW pseudopotential in XML format?  [SOLVED]

Moderators: torrent, jzwanzig

Post Reply
youhuan
Posts: 2
Joined: Sat Jul 23, 2016 4:09 pm

How to use the PAW pseudopotential in XML format?

Post by youhuan » Sat Jul 23, 2016 4:20 pm

Dear all:
I am using XML formats of PAW PSPs downloaded from
http://www.abinit.org/downloads/PAW2
The prob is that abinit-8.0.8 seems to have difficulty reading the PSPs in XML format.
The output halts immediately after this:
instrng : 63 lines of input have been read
iofn2 : Please give name of formatted atomic psp file
iofn2 : for atom type 1 , psp file is yanshi_S/PAW/S.LDA_PW-JTH.xml
inpspheads : In order to use XML pseudopotentials, you need to compile ABINIT
with the -DFOX preprocessing option, and also to compile the FoX library. Stop.
I am a beginner. Could you explain how to "compile ABINIT with the -DFOX preprocessing option, and also to compile the FoX library" in detail? Thanks a lot!
With best regards.
youhuan

Jordan
Posts: 282
Joined: Tue May 07, 2013 9:47 am

Re: How to use the PAW pseudopotential in XML format?

Post by Jordan » Mon Jul 25, 2016 8:51 am

Hi,
Although this should not happen... you can try for simplicity to recompile abinit adding

Code: Select all

--with-trio-flavor="fox"

when you do the ./configure step.
Of course, if you already have --with-trio-flavor, just add fox like this :

Code: Select all

--with-trio-flavor="whatyouhave+fox"


Cheers

Jordan

User avatar
torrent
Posts: 127
Joined: Fri Aug 14, 2009 7:40 pm

Re: How to use the PAW pseudopotential in XML format?  [SOLVED]

Post by torrent » Mon Jul 25, 2016 2:07 pm

Are you sure that you're using abinit-8.0.8 ?
This error message doesn't exist anymore in abinit v8 (and Fox is no more supported).
Check the ABINIT version you're using.
Marc Torrent
CEA - Bruyères-le-Chatel
France

youhuan
Posts: 2
Joined: Sat Jul 23, 2016 4:09 pm

Re: How to use the PAW pseudopotential in XML format?

Post by youhuan » Tue Jul 26, 2016 10:26 am

Dear Dr. Jordan and Dr. torrent:
Thank you very much for your answers. I have reexamined the ABINIT version and found the ABINIT version used is old (I have made a mistake in the ABINIT program path). I have solved this problem and thank you!
Best regards.
youhuan

Post Reply