The eigenvector with band 1 has zero norm

Moderators: torrent, jzwanzig

Post Reply
miro_ilias
Posts: 10
Joined: Thu Jul 19, 2018 8:18 pm

The eigenvector with band 1 has zero norm

Post by miro_ilias » Sat Jul 11, 2020 2:32 pm

Hello,

with abinit-8.10.3 I am trying the tutorial PAW1, https://docs.abinit.org/tutorial/paw1/ , abinit < tpaw1_1.files > log 2> err & .

However, I get the error
--- !ERROR
src_file: m_vtowfk.F90
src_line: 1136
mpi_rank: 0
message: |
The eigenvector with band 1 has zero norm.
This usually happens when the number of bands (nband) is comparable to the number of planewaves (mpw)
Action: Check the parameters of the calculation. If nband ~ mpw, then decrease nband or, alternatively, increase ecut
...
Althoug I was changing parameters ecut, pawecutdg, error remains. Any help, please ?

PS1: The same error happens also with https://docs.abinit.org/tutorial/paw1/# ... ntial-case .

PS2: However, this test works with older abinit (in debian jessie package), version 7.8.2.
Attachments
tpaw1_1.out
(46.73 KiB) Downloaded 6 times
file.log
(179.33 KiB) Downloaded 7 times

ebousquet
Posts: 415
Joined: Tue Apr 19, 2011 11:13 am
Location: University of Liege, Belgium

Re: The eigenvector with band 1 has zero norm

Post by ebousquet » Mon Jul 13, 2020 12:03 pm

Dear Miro,
This looks strange since the tuto and tests are used to test Abinit on several architectures/compilers.
What are your compilers and on which architecture (and waht return abinit -b)?
Best wishes,
Eric

miro_ilias
Posts: 10
Joined: Thu Jul 19, 2018 8:18 pm

Re: The eigenvector with band 1 has zero norm

Post by miro_ilias » Mon Jul 13, 2020 9:51 pm

Hello,
I used milias@lxir127.gsi.de:/data.local1/milias/software/abinit/abinit-8.10.3/../configure FC=mpif90 CC=mpicc --with-mpi --prefix=$PWD

giving
milias@lxir127.gsi.de:/data.local1/milias/software/abinit/abinit-8.10.3/bin/../abinit -b
--------------------------------------------------------------------------
By default, for Open MPI 4.0 and later, infiniband ports on a device
are not used by default. The intent is to use UCX for these devices.
You can override this policy by setting the btl_openib_allow_ib MCA parameter
to true.

Local host: lxir127
Local adapter: mlx4_0
Local port: 1

--------------------------------------------------------------------------
--------------------------------------------------------------------------
WARNING: There was an error initializing an OpenFabrics device.

Local host: lxir127
Local device: mlx4_0
--------------------------------------------------------------------------
DATA TYPE INFORMATION:
REAL: Data type name: REAL(DP)
Kind value: 8
Precision: 15
Smallest nonnegligible quantity relative to 1: 0.22204460E-15
Smallest positive number: 0.22250739-307
Largest representable number: 0.17976931+309
INTEGER: Data type name: INTEGER(default)
Kind value: 4
Bit size: 32
Largest representable number: 2147483647
LOGICAL: Data type name: LOGICAL
Kind value: 4
CHARACTER: Data type name: CHARACTER Kind value: 1
==== Using MPI-2 specifications ====
MPI-IO support is ON
xmpi_tag_ub ................ 8388608
xmpi_bsize_ch .............. 1
xmpi_bsize_int ............. 4
xmpi_bsize_sp .............. 4
xmpi_bsize_dp .............. 8
xmpi_bsize_spc ............. 8
xmpi_bsize_dpc ............. 16
xmpio_bsize_frm ............ 4
xmpi_address_kind .......... 8
xmpi_offset_kind ........... 8
MPI_WTICK .................. 1.000000000000000E-009

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
CPP options activated during the build:

CC_INTEL CXX_GNU FC_INTEL

HAVE_FC_ALLOCATABLE_DT... HAVE_FC_ASYNC HAVE_FC_COMMAND_ARGUMENT

HAVE_FC_COMMAND_LINE HAVE_FC_CONTIGUOUS HAVE_FC_CPUTIME

HAVE_FC_ETIME HAVE_FC_EXIT HAVE_FC_FLUSH

HAVE_FC_GAMMA HAVE_FC_GETENV HAVE_FC_GETPID

HAVE_FC_IEEE_EXCEPTIONS HAVE_FC_IOMSG HAVE_FC_ISO_C_BINDING

HAVE_FC_ISO_FORTRAN_2008 HAVE_FC_LONG_LINES HAVE_FC_MOVE_ALLOC

HAVE_FC_PRIVATE HAVE_FC_PROTECTED HAVE_FC_STREAM_IO

HAVE_FC_SYSTEM HAVE_LIBPAW_ABINIT HAVE_LIBTETRA_ABINIT

HAVE_LINALG HAVE_LINALG_SERIAL HAVE_MPI

HAVE_MPI2 HAVE_MPI_IALLREDUCE HAVE_MPI_IALLTOALL

HAVE_MPI_IALLTOALLV HAVE_MPI_INTEGER16 HAVE_MPI_IO

HAVE_MPI_TYPE_CREATE_S... HAVE_NUMPY HAVE_OS_LINUX

HAVE_TIMER_ABINIT USE_MACROAVE
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

=== Build Information ===
Version : 8.10.3
Build target : x86_64_linux_intel17.0
Build date : 20200710

=== Compiler Suite ===
C compiler : intel17.0
C++ compiler : gnu4.9
Fortran compiler : intel17.0
CFLAGS : -g -O2 -vec-report0
CXXFLAGS : -g -O2 -mtune=native -march=native
FCFLAGS : -g
FC_LDFLAGS :

=== Optimizations ===
Debug level : basic
Optimization level : standard
Architecture : intel_xeon

=== Multicore ===
Parallel build : yes
Parallel I/O : auto
openMP support : no
GPU support : no

=== Connectors / Fallbacks ===
Connectors on : yes
Fallbacks on : yes
DFT flavor : none
FFT flavor : none
LINALG flavor : netlib
MATH flavor : none
TIMER flavor : abinit
TRIO flavor : none

=== Experimental features ===
Bindings : @enable_bindings@
Exports : no
GW double-precision : no

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Default optimizations:
-O3


Optimizations for 43_ptgroups:
-O0


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

User avatar
jbeuken
Posts: 340
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: The eigenvector with band 1 has zero norm

Post by jbeuken » Thu Jul 16, 2020 10:38 pm

Hi Miro,

I compile abinit 8.10.3 with intel 17

Code: Select all

>module list
Currently Loaded Modulefiles:
  1) intel/compiler/17.0.3      2) OpenMPI/2.0.2-intel-17.0   

Code: Select all

cd tests/tutorial/Input
>cat tpaw1_1.files
tpaw1_1.in
tpaw1_1.out
tpaw1_1i
tpaw1_1o
tpaw1_1tmp
../../Psps_for_tests/6c.pspnc

Code: Select all

../../../src/98_main/abinit < tpaw1_1.files > log 2> err
>cat err
then, it works...

but if I used "Psps_for_tests/6c.lda.atompaw" , there is an error :

Code: Select all

>cat err

--- !ERROR
src_file: m_memeval.F90
src_line: 2556
mpi_rank: 0
message: |
    The value of (paw)ecutdg is zero or negative, which is forbidden.
...
which PSP do you use?

jmb
------
Jean-Michel Beuken
Computer Scientist

miro_ilias
Posts: 10
Joined: Thu Jul 19, 2018 8:18 pm

Re: The eigenvector with band 1 has zero norm

Post by miro_ilias » Fri Jul 17, 2020 9:54 am

Hello,

I use 6c.lda.atompaw, but set the parameter "pawecutdg", according to the tutorial https://docs.abinit.org/tutorial/paw1/# ... ith-abinit .

User avatar
jbeuken
Posts: 340
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: The eigenvector with band 1 has zero norm

Post by jbeuken » Fri Jul 17, 2020 3:05 pm

Hi Miro,
but set the parameter "pawecutdg"
sorry, forgot to add pawecutdg 50 in tpaw1_1.in :? :?

now

Code: Select all

../../../src/98_main/abinit < tpaw1_1.files > log 2> err
cat err
no error...

then, there's a problem with your abinit binary
which version of MPI do you use ?

can you create an ac file ( file.ac ) :

Code: Select all

enable_mpi="yes"
enable_mpi_io="yes"
with_mpi_prefix="${MPI_HOME}"
with_trio_flavor="netcdf"
with_fft_flavor="fftw3-mkl"
with_fft_incs="-I${MKLROOT}/include"
with_fft_libs="-L${MKLROOT}/lib/intel64 -Wl,--start-group  -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -Wl,--end-group -lpthread -lm -ldl"
with_linalg_flavor="mkl"
with_linalg_incs="-I${MKLROOT}/include"
with_linalg_libs="-L${MKLROOT}/lib/intel64 -Wl,--start-group  -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -Wl,--end-group -lpthread -lm -ldl"
with_dft_flavor="libxc"
enable_gw_dpc="yes" 
and run these cmds :

Code: Select all

./configure --with-config-file=./file.ac
make -j 8
good luck
------
Jean-Michel Beuken
Computer Scientist

Post Reply