PB with the installation of abinit-5.8.4 on Snow Leopard

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit 8 builds.
For a video explanation on how to build Abinit 7.x for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.
Post Reply
tchanier
Posts: 12
Joined: Wed Dec 16, 2009 5:29 pm

PB with the installation of abinit-5.8.4 on Snow Leopard

Post by tchanier » Fri Feb 26, 2010 6:55 pm

Dear All,

After upgrading my system from leopard (Mac 10.5) to snow leopard (Mac 10.6), there is now a problem with the abinit 5.8.4 installation. Abinit-5.8.4 worked well on Leopard, a 32 bit architecture. Snow leopard works in 64 bit architecture, so I just add the enable 64bit flag to the previous configure. Here is my command line for the configuration:
./configure --prefix=/home/chanier/installdir --enable-mpi="yes" --enable-mpi-io="yes" --with-mpi-prefix="/sw/openmpi" --enable-64bit-flags="yes"

I installed a new 64 bits openmpi. The new openmpi works well with abinit-6.0.1 with I just installed. With abinit-5.8.4, it issues the following error message :

LAPACK for ABINIT has been built.
touch build-stamp
lapack-abinit_5.7 has been built.
config/gnu/install-sh -c -d tmp/lib
make[4]: config/gnu/install-sh: No such file or directory
make[4]: *** [install-stamp] Error 1
make[3]: *** [package-ready] Error 2
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Does anyone has an idea how to solve this problem? What's the main difference between running abinit-5.8.4 and abinit-6.0.1? In particular, is there any additional keywords to add to abinit.in to do parallel TDDFT calculations? Since abinit-6.0.1 is a release candidate, do I need to do specific tests to see if everything is working properly?

Thank you in advance,

Best,

Thomas Chanier

User avatar
jbeuken
Posts: 353
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: PB with the installation of abinit-5.8.4 on Snow Leopard

Post by jbeuken » Sat Feb 27, 2010 7:30 pm

Hello,

it's a "classic" problem on MacOS

This is a problem related to the mkdir command, which behaves non-standardly on your system.

but the "native" /bin/mkdir makes a good job

before running configure, you may try with:

export MKDIR_P="mkdir -p"

jmb

Post Reply