error while loading shared libraries

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit 8 builds.
For a video explanation on how to build Abinit 7.x for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.
Post Reply
erichmond
Posts: 25
Joined: Fri Dec 23, 2016 12:00 am

error while loading shared libraries

Post by erichmond » Wed Oct 21, 2020 4:27 am

I'm not sure this is the right forum, but here it goes. I moved VMWare + Ubuntu + ABINIT from my old Windows 10 laptop to my new Windows 10 Workstation laptop using PC Mover by Laplink. I then upgraded VMWare to Workstation Pro 16 and Ubuntu to Ubuntu 20.04. ABINIT was working until I tried to run a program using the command abinit.
abinit<slabbulkPdslab11layer092820.files> log092820-11
The input file is attached. After I hit Enter, I received the following error message - "error while loading shared libraries: libgfortran.so.31 cannot open shared object file: no such file or directory".

I am quite lost as to what the error message is telling me to do. Can someone help?
Attachments
slabbulkPdslab11layer092820.in
(3.12 KiB) Downloaded 38 times

ebousquet
Posts: 469
Joined: Tue Apr 19, 2011 11:13 am
Location: University of Liege, Belgium

Re: error while loading shared libraries

Post by ebousquet » Mon Nov 02, 2020 9:25 am

Dear Eric,
I think you need to recompile Abinit because it looks like the path for the libraries have changed in your Ubuntu...
Best wishes,
Eric

Post Reply