error while executing make for abinit-9.2.1  [SOLVED]

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/ in the source package for detailed and up-to-date information about the configuration of Abinit 8 builds.
For a video explanation on how to build Abinit 7.x for Linux, please go to:
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.
Post Reply
Posts: 2
Joined: Thu Oct 08, 2020 2:06 pm

error while executing make for abinit-9.2.1  [SOLVED]

Post by nickb » Thu Oct 08, 2020 2:38 pm

Hi all,

I am experiencing the same error message described at the beginning of this thread (make[5]: *** No rule to make target 'm_optim_dumper.F90', needed by 'm_optim_dumper.o'. Stop.) but as far as I can see have set linalg correctly. I am working on Ubuntu LTS 18.04 and followed the guide posted in the same thread. I have attached my config.log file and pasted the final remarks of running the config script below.

Core build parameters

* C compiler : gnu version 7.5
* Fortran compiler : gnu version 7.5
* architecture : unknown unknown (64 bits)
* debugging : basic
* optimizations : standard

* OpenMP enabled : no (collapse: ignored)
* MPI enabled : yes (flavor: auto)
* MPI in-place : no
* MPI-IO enabled : yes
* GPU enabled : no (flavor: none)

* LibXML2 enabled : yes
* LibPSML enabled : no
* XMLF90 enabled : no
* HDF5 enabled : yes (MPI support: yes)
* NetCDF enabled : yes (MPI support: yes)
* NetCDF-F enabled : yes (MPI support: yes)

* FFT flavor : fftw3 (libs: user-defined)
* LINALG flavor : netlib (libs: user-defined)

* Build workflow : monolith

0 deprecated options have been used:.

Configuration complete.

I was wondering if perhaps it is linked to the "* MPI in-place : no" line in the core build parameters. Please let me know if any more information is required to diagnose the issue. If it is relevant, the machine I am compiling on is an AMD Threadripper 1920X.

Thanks in advance.

(184.5 KiB) Downloaded 36 times

User avatar
Site Admin
Posts: 33
Joined: Thu Sep 17, 2009 9:49 am

Re: error while executing make for abinit-9.2.1

Post by admin » Tue Oct 13, 2020 6:38 pm

Dear ,
Could your problem the same as this one that has been solved:
viewtopic.php?f=3&t=4482 ?
There was a similar question before, please check if it is not in some previous posts.
Best wishes,

Posts: 2
Joined: Thu Oct 08, 2020 2:06 pm

Re: error while executing make for abinit-9.2.1

Post by nickb » Wed Oct 14, 2020 12:09 pm

Apologies, despite reading that thread I somehow missed the post regarding creating a symlink for python. That was the exact problem. Please feel free to close/delete this thread.

Post Reply