Do you experience trouble to compile with NetCDF ?

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit 8 builds.
For a video explanation on how to build Abinit 7.x for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.
Post Reply
gonze
Posts: 397
Joined: Fri Aug 14, 2009 8:29 pm

Do you experience trouble to compile with NetCDF ?

Post by gonze » Tue Feb 09, 2010 2:39 pm

Dear ABINIT users,

In the forthcoming months, it is planned that ABINIT rely more on NetCDF by default.
Before starting this change of standard mode of writing, we would like to know whether
some people still experience some problem with NetCDF ...

The enabling of NetCDF at configure time has been the default since 5.6 , more than one year ago.
If you experience problems, could you give a try to ABINITv6.0.1 :
http://www.abinit.org/downloads/source- ... ases/6.0.1
If NetCDF does not compile properly with this latest version (release candidate), please reply to this post,
and describe your problem.

Xavier

tchanier
Posts: 12
Joined: Wed Dec 16, 2009 5:29 pm

Re: Do you experience trouble to compile with NetCDF ?

Post by tchanier » Sat Feb 27, 2010 8:08 am

Dear All,

I am trying to compile ABINIT-6.0.1 with the netcdf library. First, is the library included in the abinit package or is it necessary to have the netcdf library prefix to the netcdf library? Second, I tried to compile giving the netcdf library path :

./configure --prefix=/home/chanier/installdir --enable-mpi="yes" --enable-mpi-io="yes" --with-mpi-prefix="/sw/openmpi" --enable-64bit-flags="yes" --enable-netcdf="yes" --enable-netcdf-libs=/usr/lib/netcdf/lib/

The configuration fails. It issues the following error message:

==============================================================================
=== Option consistency checking ===
==============================================================================

configure: checking consistency of external prerequisite options
configure: |---> all OK
configure:
configure: checking consistency of plug-in options
configure: |---> all OK
configure:
configure: parsing command-line options
configure: error: invalid library statement in with_netcdf_libs: /home/chanier/usr/lib/netcdf-4.0.1/lib/

How to solve this problem? Thank you in advance.

Best,

Thomas Chanier

User avatar
jbeuken
Posts: 353
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: Do you experience trouble to compile with NetCDF ?

Post by jbeuken » Sat Feb 27, 2010 4:29 pm

Hello Thomas,

can you try with this syntax :

--with-netcdf-includes="-I/usr/lib/netcdf/include"
--with-netcdf-libs="-L/usr/lib/netcdf/lib -lnetcdf"


jmb
------
Jean-Michel Beuken
Computer Scientist

Post Reply