Configuring with MPI  [SOLVED]

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit builds.
For a video explanation on how to build Abinit for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.

Configuring with MPI

Postby emily » Tue Jun 04, 2019 4:06 pm

When I configure and enable MPI, on version 8.10.2 it stops at this

==============================================================================
=== Multicore architecture support ===
==============================================================================

checking whether to enable OpenMP support... no
checking whether to build MPI code... yes
checking whether the C compiler supports MPI... no
checking whether the C++ compiler supports MPI... no
checking whether the Fortran Compiler supports MPI... no
checking whether MPI is usable... no
configure: error: MPI support is broken - please fix your config parameters and/or MPI installation

Can anyone help? I have attached the log file.
Attachments
config.log
(99.18 KiB) Downloaded 38 times
emily
 
Posts: 2
Joined: Tue Jun 04, 2019 2:34 pm

Re: Configuring with MPI

Postby ebousquet » Tue Jun 04, 2019 4:21 pm

Dear Emily,
Could you send your config file .ac you used or the list of options you've put to run the configure?
But it sounds like there is something wrong in the installation of MPI on your machine...
Thanks,
Eric
ebousquet
 
Posts: 303
Joined: Tue Apr 19, 2011 11:13 am
Location: University of Liege, Belgium

Re: Configuring with MPI

Postby gmatteo » Tue Jun 04, 2019 4:24 pm

The error message given in config.log

configure:23078: checking whether the Fortran Compiler supports MPI
configure:23332: gfortran -o conftest -g -ffree-line-length-none conftest.F90 -L/usr/lib/gcc/x86_64-linux-gnu/5 -L/usr/lib/gcc/x86_64-linux-gnu/5/../../../x86_64-linux-gnu -L/usr/lib/gcc/x86_64-linux-gnu/5/../../../../lib -L/lib/x86_64-linux-gnu -L/lib/../lib -L/usr/lib/x86_64-linux-gnu -L/usr/lib/../lib -L/usr/lib/gcc/x86_64-linux-gnu/5/../../.. -lgfortran -lm -lquadmath >&5
conftest.F90:3: Error: Can't open included file 'mpif.h'
configure:23332: $? = 1


shows that you are trying to compile a parallel version with gfortran whereas one should use the mpif90 wrapper.

First of all, are you sure that mpif90 and the MPI library are installed on your machine?
What is the output of the linux command: which mpif90 ?

A user guide explaining how to configure and compile the parallel version on laptops and supercomputers is available at
https://wiki.abinit.org/lib/exe/fetch.p ... abinit.pdf
User avatar
gmatteo
 
Posts: 252
Joined: Sun Aug 16, 2009 5:40 pm

Re: Configuring with MPI  [SOLVED]

Postby emily » Wed Jun 05, 2019 3:48 pm

Hi,

Thanks for helping me. The first one was run using ./configure --enable-mpi

I also tried ./configure --enable-mpi FC=mpif90 and it returns this error

==============================================================================
=== Multicore architecture support ===
==============================================================================

checking whether to enable OpenMP support... no
checking whether to build MPI code... yes
checking whether the C compiler supports MPI... no
checking whether the C++ compiler supports MPI... no
checking whether the Fortran Compiler supports MPI... yes
checking whether MPI is usable... no
configure: error: MPI support is broken - please fix your config parameters and/or MPI installation

So now the Fortran Compiler supports MPI but MPI is still not usable? Does this mean there is something wrong with the MPI installation on the machine then?

Edit: I managed to get to configured with MPI.
emily
 
Posts: 2
Joined: Tue Jun 04, 2019 2:34 pm


Return to Configuration

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron