Abinit not compatible with libxc-4.x.y

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit builds.
For a video explanation on how to build Abinit for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.

Abinit not compatible with libxc-4.x.y

Postby frodo » Tue Mar 05, 2019 7:53 am

Hello,

I'm working on abinit 8.10.2 with libxc. I noted that the fallback library is libxc-3.0.0 and that the configure script tests for the libxc version being in the range 2.2 <->4.2.

The tddft.org website lists libxc-3.0.1 (the last in the 3 series) as having almost a dozen bug fixes, so i downloaded and built that, and then built abinit. This went well, with the libxc tests showing 6 passed and 29 succeeded.

Then I did the same thing with libxc-4.0.0, which is supposed to be in the acceptable version range for libxc. However, now the libxc tests show 13 failed, 4 passed, and 18 succeeded. 5 of the failures are because of SCF convergence in a different number of iterations and the remaining 8 are because the erroneous lines exceeded the tolnlines value for the test (e.g., 117 instead of 0 for t68). Inspecting the .out files for the failed tests shows that the numerical differences are substantial in a number of places.

Curious whether this was just a buggy early 4.0 version, I zoomed ahead to libxc-4.3.3. I bypassed the abinit configure check to build with this version. The libxc test results were identical to that for libxc-4.0.0, with the same 13 tests failing. I then went a step further and compared the .out files for all 35 libxc tests, either compiled with libxc-4.0.0 or libxc-4.3.3. Every single pair of files were completely identical. There was zero change in output using either libxc-4.0.0 or libxc-4.3.3.

I conclude that abinit is not compatible with libxc-4.x.y, even if x<=2. If this is incorrect, please let me know. If true, than at a minimum, the libxc version test in configure should be corrected.

Best Regards
frodo
 
Posts: 12
Joined: Mon Feb 11, 2019 8:35 pm

Return to Configuration

Who is online

Users browsing this forum: No registered users and 2 guests

cron