Configuration failure: C preprocessor  [SOLVED]

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit builds.
For a video explanation on how to build Abinit for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.

Configuration failure: C preprocessor  [SOLVED]

Postby zlevine@nist.gov » Wed Dec 19, 2018 11:11 pm

I am trying to install abinit-8.10.1 on a second computer. On my home machine, I succeeded without problem. The OS is: 3.10.0-862.14.4.el7.x86_64, so GNU/Linux Red Hat Enterprise 7.

I ran

./configure --prefix=/home/zlevine/Code/Abinit/abinit-8.10.1/Abinit --with-mpi-prefix=/usr/lib64/openmpi

It ends with this:

checking for /share/sw/pgi/linux86-64/17.10/bin/pgcc... no
configure: error: could not run C preprocessor "/share/sw/pgi/linux86-64/17.10/bin/pgcc -Mcpp"

I tried both:
./configure --prefix=/home/zlevine/Code/Abinit/abinit-8.10.1/Abinit --with-mpi-prefix=/usr/lib64/openmpi
./configure --prefix=/home/zlevine/Code/Abinit/abinit-8.10.1/Abinit --with-mpi-prefix=/usr/lib64/openmpi CPP="/share/sw/pgi/linux86-64/17.10/bin/pgcc -Mcpp"

The odd thing is that I have that program:

ls -l /share/sw/pgi/linux86-64/17.10/bin/pgcc
-r-xr-xr-x 1 root root 208336 Oct 30 2017 /share/sw/pgi/linux86-64/17.10/bin/pgcc*

Also, if I do
/share/sw/pgi/linux86-64/17.10/bin/pgcc -Mcpp hello.c

on a simple file with C preprocessor commands, it responds correctly, making a "hello.i" file.

So why is it failing the check for the C preprocessor?

I thought perhaps it would be better to use gcc. So I did this:

./configure --prefix=/home/zlevine/Code/Abinit/abinit-8.10.1/Abinit CC="/usr/bin/gcc" CPP="/usr/bin/gcc -E"

That leads to a similar error. (Taking out the mpi without gcc also leads to a similar error as above.)

configure: error: could not run C preprocessor "/usr/bin/gcc -E"

What to do?
zlevine@nist.gov
 
Posts: 1
Joined: Wed Dec 19, 2018 10:17 pm
Location: NIST, Gaithersburg, MD, USA

Re: Configuration failure: C preprocessor

Postby jbeuken » Thu Dec 27, 2018 7:49 pm

Sorry but, there has been no more PGI support for a long time....
PGI has some difficulties to compile ABINIT :?
User avatar
jbeuken
 
Posts: 306
Joined: Tue Aug 18, 2009 9:24 pm


Return to Configuration

Who is online

Users browsing this forum: No registered users and 4 guests