Segmentation fault with mkl in parallel version

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/ in the source package for detailed and up-to-date information about the configuration of Abinit 8 builds.
For a video explanation on how to build Abinit 7.x for Linux, please go to:
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.
Post Reply
Posts: 5
Joined: Mon Nov 19, 2018 12:33 am

Segmentation fault with mkl in parallel version

Post by Hiroki » Thu Nov 29, 2018 8:47 am

Dear abinit developers/users

I got a segmentation fault when I tried to run abinit, which compiled with mkl as linalg:

Code: Select all

forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image              PC                Routine            Line        Source   00002AAAB2844F0C  for__signal_handl     Unknown  Unknown
libpthread-2.17.s  00002AAAB4D42680  Unknown               Unknown  Unknown        00002AAAB5259740  Unknown               Unknown  Unknown        00002AAAB525C02C  Unknown               Unknown  Unknown   00002AAAB2887FB9  for_deallocate        Unknown  Unknown   00002AAAB2819CED  for_dealloc_all_n     Unknown  Unknown
abinit             00000000005EFBDC  Unknown               Unknown  Unknown
abinit             00000000005CE076  Unknown               Unknown  Unknown
abinit             00000000005A055B  Unknown               Unknown  Unknown
abinit             0000000000559340  Unknown               Unknown  Unknown
abinit             000000000055039D  Unknown               Unknown  Unknown

Compile options are below:

Code: Select all

./configure \
--enable-mpi --enable-openmp FC=mpifort CC=mpicc\
with_linalg_libs="-L/usr/tce/packages/mkl/mkl-2019.0/mkl/lib/intel64/ -lmkl_blas95_lp64 -lmkl_lapack95_lp64 -lmkl_intel_lp64 -lmkl_core -lmkl_sequential -lpthread -lm"\
with_fft_libs="-L/usr/tce/packages/mkl/mkl-2019.0/mkl/lib/intel64/ -Wl,--start-group -lmkl_intel_lp64 -lmkl_core -lmkl_sequential -Wl,--end-group"

This error didn't occur when I ran small sample calculation,
(e.g. /v3/,
and also didn't occur when I compiled without mkl and fftw3:

Code: Select all

./configure --enable-mpi --enable-openmp FC=mpifort CC=mpicc

I'm guessing the problem is the parallelization because the small calculation had done.
But, according to other posts, mkl works with mpi...
What's the problem?
I may need mkl to calculate the response function (iscf=-3).
Or is there the appropriate linalg instead of mkl?

ABINIT version is 8.8.4, and the executable is parallelized.
For parallel version, I used "autoparal 1" in the sample file.
The used pseudopotential is "Al.GGA_PBE-JTH.xml", which is distributed in ABINIT web.

Sincerely yours,

Post Reply