Error message in compiling 8.8.1  [SOLVED]

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit builds.
For a video explanation on how to build Abinit for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.

Error message in compiling 8.8.1

Postby natalie » Tue May 08, 2018 9:39 am

I am always amazed and grateful when abinit compiles without error, but for 8.8.1, the script I have been using for several previous versions failed. The compile script that failed is:
-----------------
#!/bin/tcsh

source /etc/profile.d/modules.csh
module load openmpi/1.6-intel

../configure --prefix=/home/natalie/EL6/publiccode/abinit/abinit-8.8.1 --exec-prefix=/home/natalie/EL6/publiccode/abinit/abinit-8.8.1 --enable-mpi --with-mpi- prefix=/deac/opt/openmpi/1.6-intel --with-fft-flavor=fftw3-mkl --with-linalg-flavor=mkl --with-dft-flavor=libxc --with-trio-flavor=netcdf FC=mpif90 CC=mpicc CPP='mpicc -E --no-create --no-recursion'

make
make install
--------------------------------
Several modules compiled correctly, but the error occurred in 78_eph. Thanks in advance for any suggestions. I cannot upload the full log file, but the bottom of the file looks like:
------------------------
make[2]: Leaving directory `/home/natalie/EL6/publiccode/abinit/abinit-8.8.1/cmd
/src/78_effpot'
Making install in 78_eph
make[2]: Entering directory `/home/natalie/EL6/publiccode/abinit/abinit-8.8.1/cm
d/src/78_eph'
mpif90 -DHAVE_CONFIG_H -I. -I../../../src/78_eph -I../.. -I../../src/77_ddb -I.
./../../src/77_ddb -I../../src/59_ionetcdf -I../../../src/59_ionetcdf -I../../sr
c/27_toolbox_oop -I../../../src/27_toolbox_oop -I../../src/42_libpaw -I../../../
src/42_libpaw -I../../src/72_response -I../../../src/72_response -I../../src/66_
nonlocal -I../../../src/66_nonlocal -I../../src/17_libtetra_ext -I../../../src/1
7_libtetra_ext -I../../src/62_iowfdenpot -I../../../src/62_iowfdenpot -I../../sr
c/18_timing -I../../../src/18_timing -I../../src/12_hide_mpi -I../../../src/12_h
ide_mpi -I../../src/14_hidewrite -I../../../src/14_hidewrite -I../../src/69_wfde
sc -I../../../src/69_wfdesc -I../../src/32_util -I../../../src/32_util -I../../s
rc/28_numeric_noabirule -I../../../src/28_numeric_noabirule -I../../src/44_abity
pes_defs -I../../../src/44_abitypes_defs -I../../src/61_occeig -I../../../src/61
_occeig -I../../src/16_hideleave -I../../../src/16_hideleave -I../../src/65_paw
-I../../../src/65_paw -I../../src/56_recipspace -I../../../src/56_recipspace -I.
./../src/52_fft_mpi_noabirule -I../../../src/52_fft_mpi_noabirule -I../../src/66
_wfs -I../../../src/66_wfs -I../../src/41_geometry -I../../../src/41_geometry -I
../../src/11_memory_mpi -I../../../src/11_memory_mpi -I../../src/10_defs -I../..
/../src/10_defs -I../../src/53_ffts -I../../../src/53_ffts -I../../src/incs -I..
/../../src/incs -I/home/natalie/EL6/publiccode/abinit/abinit-8.8.1/cmd/fallbacks
/exports/include -I/home/natalie/EL6/publiccode/abinit/abinit-8.8.1/cmd/fallbacks/exports/include -free -module /home/natalie/EL6/publiccode/abinit/abinit-8.8.1/cmd/src/mods -O3 -g -extend-source -vec-report0 -noaltparam -nofpscomp -c -o m_sigmaph.o ../../../src/78_eph/m_sigmaph.F90
../../../src/78_eph/m_sigmaph.F90(2389): error #5274: Token incorrectly continued across lines
netcdf_check(nf90_put_var(self%ncid, nctk_idname(self%ncid, "vals_e0ks"), c2r(self%vals_e0ks), start=[1,1,1,ikcalc,spin]),"No msg from caller"&
^
../../../src/78_eph/m_sigmaph.F90(2413): error #5274: Token incorrectly continued across lines
netcdf_check(nf90_put_var(self%ncid, nctk_idname(self%ncid, "vals_wr"), c2r(self%vals_wr), start=[1,1,1,1,ikcalc,spin]),"No msg from caller"&
^
compilation aborted for ../../../src/78_eph/m_sigmaph.F90 (code 1)
make[2]: *** [m_sigmaph.o] Error 1
make[2]: Leaving directory `/home/natalie/EL6/publiccode/abinit/abinit-8.8.1/cmd/src/78_eph'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/natalie/EL6/publiccode/abinit/abinit-8.8.1/cmd/src'
make: *** [install-recursive] Error 1
natalie
 
Posts: 16
Joined: Sun Jan 17, 2010 11:24 pm

Re: Error message in compiling 8.8.1

Postby gmatteo » Sun May 13, 2018 12:30 am

I was not able to reproduce the problem with the intel-based configurations we use for the test farm
but I think the compilation error is due to the preprocessing done by the compiler.

From your error message, it seems that one of the CPP macros used in the code
goes beyond the 132 column limit of F90 and the preprocessor does not handle it correctly.

Could you try to pass FCFLAGS_EXTRA="-stand f03" to configure?

If this doesn't work, I would suggest to change manually the include file in src/incs/abi_common.h
by setting:

#undef HAVE_FC_LONG_LINES

at the beginning of the file

PS: Could you post the output of abinit -b ?

Matteo
User avatar
gmatteo
 
Posts: 252
Joined: Sun Aug 16, 2009 5:40 pm

Re: Error message in compiling 8.8.1  [SOLVED]

Postby natalie » Mon May 14, 2018 3:48 pm

Dear Matteo,
Thanks for your helpful reply. I did succeed in the installation by using a more recent version of openmpi. The abinit -b output follows. At the end I have some documentation for the earlier openmpi version and its error messages.
DATA TYPE INFORMATION:
REAL: Data type name: REAL(DP)
Kind value: 8
Precision: 15
Smallest nonnegligible quantity relative to 1: 0.22204460E-15
Smallest positive number: 0.22250739-307
Largest representable number: 0.17976931+309
INTEGER: Data type name: INTEGER(default)
Kind value: 4
Bit size: 32
Largest representable number: 2147483647
LOGICAL: Data type name: LOGICAL
Kind value: 4
CHARACTER: Data type name: CHARACTER Kind value: 1
==== Using MPI-2 specifications ====
MPI-IO support is ON
xmpi_tag_ub ................ 2147483647
xmpi_bsize_ch .............. 1
xmpi_bsize_int ............. 4
xmpi_bsize_sp .............. 4
xmpi_bsize_dp .............. 8
xmpi_bsize_spc ............. 8
xmpi_bsize_dpc ............. 16
xmpio_bsize_frm ............ 4
xmpi_address_kind .......... 8
xmpi_offset_kind ........... 8
MPI_WTICK .................. 1.000000000000000E-009

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
CPP options activated during the build:

CC_INTEL CXX_INTEL FC_INTEL

HAVE_FC_ALLOCATABLE_DT... HAVE_FC_ASYNC HAVE_FC_COMMAND_ARGUMENT

HAVE_FC_COMMAND_LINE HAVE_FC_CONTIGUOUS HAVE_FC_CPUTIME

HAVE_FC_ETIME HAVE_FC_EXIT HAVE_FC_FLUSH

HAVE_FC_GAMMA HAVE_FC_GETENV HAVE_FC_GETPID

HAVE_FC_IEEE_EXCEPTIONS HAVE_FC_IOMSG HAVE_FC_ISO_C_BINDING

HAVE_FC_ISO_FORTRAN_2008 HAVE_FC_LONG_LINES HAVE_FC_MOVE_ALLOC

HAVE_FC_PRIVATE HAVE_FC_PROTECTED HAVE_FC_STREAM_IO

HAVE_FC_SYSTEM HAVE_FFT HAVE_FFT_FFTW3_MKL

HAVE_FFT_MPI HAVE_FFT_SERIAL HAVE_LIBPAW_ABINIT

HAVE_LIBTETRA_ABINIT HAVE_LIBXC HAVE_LINALG

HAVE_LINALG_SERIAL HAVE_MPI HAVE_MPI2

HAVE_MPI_IALLREDUCE HAVE_MPI_IALLTOALL HAVE_MPI_IALLTOALLV

HAVE_MPI_INTEGER16 HAVE_MPI_IO HAVE_MPI_TYPE_CREATE_S...

HAVE_NETCDF HAVE_NUMPY HAVE_OS_LINUX

HAVE_TIMER_ABINIT USE_MACROAVE
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

=== Build Information ===
Version : 8.8.1
Build target : x86_64_linux_intel17.0
Build date : 20180513

=== Compiler Suite ===
C compiler : intel17.0
C++ compiler : intel17.0
Fortran compiler : intel17.0
CFLAGS : -g -O2 -vec-report0
CXXFLAGS : -g -O2 -vec-report0
FCFLAGS : -g
FC_LDFLAGS :

=== Optimizations ===
Debug level : basic
Optimization level : standard
Architecture : intel_xeon

=== Multicore ===
Parallel build : yes
Parallel I/O : auto
openMP support : no
GPU support : no
=== Connectors / Fallbacks ===
Connectors on : yes
Fallbacks on : yes
DFT flavor : libxc-fallback
FFT flavor : fftw3-mkl
LINALG flavor : mkl
MATH flavor : none
TIMER flavor : abinit
TRIO flavor : netcdf-fallback

=== Experimental features ===
Bindings : @enable_bindings@
Exports : no
GW double-precision : no

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Default optimizations:
-O3

Optimizations for 20_datashare:
-O0

--------------------------------------------------------------------------------
Some comments on the openmpi 1.6/intel12.0 version which failed. --
Using the flag -- FCFLAGS_EXTRA="-stand f03" did solve the long line problem, but caused a later error in the compilation with
the error message
"../../../src/78_eph/m_sigmaph.F90(1114): warning #7416: Fortran 2003 does not allow this intrinsic procedure. [DCMPLX]
dkpap = dcmplx(displ_cart(1, idir2, ipert2, nu), displ_cart(2, idir2, ipert2, nu))
---------------------^
../../../src/78_eph/m_sigmaph.F90(1115): warning #7416: Fortran 2003 does not allow this intrinsic procedure. [DCONJG]
tpp(ip1,ip2) = dka * dconjg(dkap) + dkpa * dconjg(dkpap) ...."

I did not yet try your other suggestions, but will keep them in mind for the future. It is our experience that this version (2.1.0) of openmpi does not always
work for large calculations... Your recommendations are very much appreciated. Thanks! Natalie
natalie
 
Posts: 16
Joined: Sun Jan 17, 2010 11:24 pm

Re: Error message in compiling 8.8.1

Postby pomax » Tue Jul 30, 2019 3:44 pm

Hi, I'm a bit late but I guess it could help others if I post my solution.

I've had a similar error during make on version 8.11.8 because my gfortran version was lower than 5 (I had 4.8).
I am on Centos7 so I had to install devtools-7 then install gfortran-7. The installation seems to work, still got an error F77 unknown tag though.
Here's the code I've written into the terminal (I don't think the second line is necessary).
Code: Select all
sudo yum install centos-release-scl
sudo yum-config-manager --enable rhel-server-rhscl-7-rpms
sudo yum install devtoolset-7
scl enable devtoolset-7 bash
sudo yum update gfortran


And write the following line to enable gfortran-7 instead of your old version into a new terminal window :
Code: Select all
scl enable devtoolset-7 bash

Or this line into .bashrc to have it automatically every time you open the terminal :
Code: Select all
source scl_source enable devtoolset-7
pomax
 
Posts: 5
Joined: Wed Jun 05, 2019 5:40 pm


Return to Configuration

Who is online

Users browsing this forum: No registered users and 1 guest