OpenMP Support with Intel 19.1 Compiler

option, parallelism,...

Moderators: jbeuken, Jordan, pouillon

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit 8 builds.
For a video explanation on how to build Abinit 7.x for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green V-like button on its upper-right corner to accept it.
Post Reply
JenniferCarter
Posts: 1
Joined: Fri Jul 17, 2020 4:55 am

OpenMP Support with Intel 19.1 Compiler

Post by JenniferCarter » Fri Jul 17, 2020 4:31 pm

Dear All,
We are using the latest release of the Intel Parallel Studio XE Professional. This comes with the Intel 19.1 compiler suite. I am struggling with 2 things:

1/ I am not able to build ABINIT v8.10.3 with openMP support.
enable_openmp="yes" is not working. Seems like adding this to config file is causing the build system to start looking for gfortran compiler. If I switch this off then build goes forward fine.

2/ Build system keeps ignoring the MKL libraries. I get
* MATH flavor = none (libs: ignored)

Please see my config and results below:

config file

CC=mpiicc;
FC=mpiifort;
CXX=mpiicpc;

#enable_openmp="yes"
enable_mpi="yes"
enable_mpi_inplace="yes"
with_mpi_incs="-I${I_MPI_ROOT}/intel64/include"
with_mpi_libs="-L${I_MPI_ROOT}/intel64/lib -lmpi"

with_fft_incs="-I${MKLROOT}/include"
with_fft_libs="-L${MKLROOT}/lib/intel64 -Wl,--start-group -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -Wl,--end-group -lpthread -lm -ldl"
with_fft_flavor="fftw3-mkl"

with_linalg_incs="-I${MKLROOT}/include"
with_linalg_libs="-L${MKLROOT}/lib/intel64 -Wl,--start-group -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -Wl,--end-group -lpthread -lm -ldl"
with_linalg_flavor="mkl"

ConfigResults
Summary of important options:

* C compiler : intel version 19.1
* Fortran compiler: intel version 19.1
* architecture : intel xeon (64 bits)

* debugging : basic
* optimizations : standard

* OpenMP enabled : no (collapse: ignored)
* MPI enabled : yes
* MPI-IO enabled : auto
* GPU enabled : no (flavor: none)

* TRIO flavor = none
* TIMER flavor = abinit (libs: ignored)
* LINALG flavor = mkl (libs: user-defined)
* ALGO flavor = none (libs: ignored)
* FFT flavor = fftw3-mkl (libs: user-defined)
* MATH flavor = none (libs: ignored)
* DFT flavor = none

Configuration complete.
You may now type "make" to build ABINIT.
(or, on a SMP machine, "make mj4", or "make multi multi_nprocs=<n>")

User avatar
jbeuken
Posts: 340
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: OpenMP Support with Intel 19.1 Compiler

Post by jbeuken » Sat Jul 18, 2020 10:19 pm

Hi,
1/ I am not able to build ABINIT v8.10.3 with openMP support.
enable_openmp="yes" is not working. Seems like adding this to config file is causing the build system to start looking for gfortran compiler. If I switch this off then build goes forward fine.
abinit 8.10.3 has never been officially tested with Intel 19.1 :cry:
some hints are missing in build system for this compiler version ( add FCFLAGS_EXTRA="-qopenmp" )
but, you need to config your linalg with OpenMP support ( noticed this option : -liomp5 )
( untested, but if you have any problems, feel free to come back to me... )

Code: Select all

FCFLAGS_EXTRA="-qopenmp"
enable_openmp="yes"

with_linalg_flavor = mkl
with_linalg_libs = -L${MKLROOT}/lib/intel64 -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -liomp5 -lpthread -lm -ldl
with_fft_flavor = dfti
with_fft_libs = -L${MKLROOT}/lib/intel64 -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -liomp5 -lpthread -lm -ldl
you can use MKL Advisor to set this config...
2/ Build system keeps ignoring the MKL libraries. I get
* MATH flavor = none (libs: ignored)
this option is to choose special math library like GSL

Code: Select all

with_math_flavor="gsl"
jmb
------
Jean-Michel Beuken
Computer Scientist

Post Reply