ABINITv7.6.2

Read this before submitting your first post to any question
Forum rules
Nettiquette: READ BEFORE SUBMITTING ANY POSTS

ABINITv7.6.2

Postby gonze » Tue Feb 18, 2014 12:36 pm

Dear ABINIT users,

ABINIT version 7.6.2 is available ...
You will find it on the Web site,
http://www.abinit.org/downloads/source- ... s/abinit-1

*** This release of ABINIT is a production version ***

Compared with v7.6.1, in v7.6.2 there are some bug fixes in the DMFT part, when used in parallel.
Other fixes are also present, e.g. for specific platforms or compilers, formats, etc .

For the new features of v7.6 compared to v7.4, please, see the release notes, at
http://www.abinit.org/documentation/hel ... notes.html


Please, read the installation notes at
http://www.abinit.org/documentation/hel ... stall.html

For the list of contributors, see the above-mentioned release notes.

Have fun !
Xavier

------------------------------------------------------------------------

MPORTANT NOTICE :
In v7.7 , some cleaning has started, breaking specific backward compatibilities. In particular,
the input variable mkmem (and associated mkqmem, mk1mem, mffmem) will be removed. Explicitly, no calculation
using out-of-core storing of wavefunctions will be possible. Instead, the user should rely on the parallelisation,
with distributed memory. This was decided at the developer's workshop in Dinard, May 2013. Indeed, the maintenance of
mkmem was becoming a barrier to more interesting features, related to parallelisation.

By the same token, some developers are considering further cleaning of ABINIT (e.g. removal of the ACFD capabilities of ABINIT, removal of LWF) also to favour new developments over outdated or badly implemented features.
The header of the WFK files might also be changed, breaking further backward compatibility.
The ABINIT Wiki (http://wiki.abinit.org/) will be activated and the whole
documentation will be progressively transferred there. Once this is completed,
the wiki will become the reference for documentation.
Also, the availability of NetCDF and MPI-IO (in case of parallelism) might become mandatory.

At the end, ABINITv7.8 might turn out to be called ABINIT v8 , to emphasize these changes, and mark such loss of backward compatibility, or such new requirements for the libraries on which ABINIT relies.
gonze
 
Posts: 355
Joined: Fri Aug 14, 2009 8:29 pm

Return to News & Announcements

Who is online

Users browsing this forum: No registered users and 1 guest

cron