configure: error: MPI support is broken in CentOS 5.10  [SOLVED]

HPC, IBM, Mac OS, Windows, ...

Moderators: jbeuken, Jordan, gmatteo

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit builds.
For a video explanation on how to build Abinit for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green button on its upper-right corner to accept it.
Post Reply
shohams
Posts: 4
Joined: Mon Apr 06, 2020 2:01 am
Location: Pittsburgh, PA

configure: error: MPI support is broken in CentOS 5.10

Post by shohams » Thu Apr 09, 2020 1:19 am

I was trying to run the ./ configure command in a CentOS 5.10 system:
./configure --with-config-file="./shohams.ac",
but I kept getting the following error
==============================================================================
=== Multicore architecture support ===
==============================================================================

checking whether to enable OpenMP support... no
checking whether to build MPI code... yes
checking whether MPI is usable... no
configure: error: MPI support is broken - please fix your config parameters and/or MPI installation

I am not sure what I should do to proceed. If you want I can attach the "config.log" and the "shohams.ac" file; as of now I cannot add it. I would really appreciate the help, thanks.

User avatar
jbeuken
Posts: 322
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: configure: error: MPI support is broken in CentOS 5.10

Post by jbeuken » Mon Apr 13, 2020 9:02 pm

Hi,

Centos 5.10 is too old...

What is the version of your compiler ( GNU I suppose ) ?

GNU gfortran < 5.3 is no more supported

regards

jmb
------
Jean-Michel Beuken
Computer Scientist

shohams
Posts: 4
Joined: Mon Apr 06, 2020 2:01 am
Location: Pittsburgh, PA

Re: configure: error: MPI support is broken in CentOS 5.10

Post by shohams » Mon Apr 13, 2020 9:50 pm

Hello J Beuken,
I am using the intel fortran compiler, "ifort (IFORT) 15.0.3"

User avatar
jbeuken
Posts: 322
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: configure: error: MPI support is broken in CentOS 5.10

Post by jbeuken » Tue Apr 14, 2020 12:24 pm

ok with intel 15... :
which kind of intel package ?
- Parallel Studio XE Professional Edition ?
- Parallel Studio XE Cluster Edition for Linux ( include MPI stack ) ?
which version of MPI ? ( MPICH 3 / OpenMPI ) ?

can you show me the content of your ac file ?

jmb
------
Jean-Michel Beuken
Computer Scientist

shohams
Posts: 4
Joined: Mon Apr 06, 2020 2:01 am
Location: Pittsburgh, PA

Re: configure: error: MPI support is broken in CentOS 5.10

Post by shohams » Thu Apr 16, 2020 9:32 pm

1. Intel package

Code: Select all

ifort --version
ifort (IFORT) 15.0.3 20150407
Copyright (C) 1985-2015 Intel Corporation.  All rights reserved.
2. MPI version

Code: Select all

mpiexec --version
Intel(R) MPI Library for Linux, 64-bit applications, Version 4.1  Build 20120831
Copyright (C) 2003-2012 Intel Corporation.  All rights reserved.
3. shohams.ac

Code: Select all

#prefix="/usr/local"
enable_mpi="yes"
enable_mpi_io="yes"
#with_mpi_incs="-I/opt/intel/impi/4.1.0.024/intel64/include"
with_mpi_prefix="/opt/intel/impi/4.1.0.024/intel64/bin"
with_fft_flavor="fftw3"
with_fft_incs="-I/usr/local/packages/fftw-3.3.4/include/"
#with_fft_libs="-L/usr/lib/x86-64-linux-gnu/ -lfftw3 -lfftw3f"
with_fft_libs="-L/usr/local/packages/fftw-3.3.4/lib -lfftw3_mpi -lfftw3"
#with_linalg_flavor="atlas"
#with_linalg_libs="-L/usr/lib64 -llapack -lf77blas -lcblas -latlas"
with_linalg_flavor="mkl"
with_linalg_libs="-L/opt/intel/composer_xe_2015.3.187/mkl/lib/intel64 \
          -lmkl_scalapack_lp64 -lmkl_sequential \
          -Wl,--start-group -lmkl_blacs_intelmpi_lp64 -lmkl_lapack95_lp64 \
          -lmkl_intel_lp64 -lmkl_intel_thread \
          -lmkl_core -Wl,--end-group -liomp5 -lpthread"
#with_dft_flavor="libxc"
#with_dft_flavor="atompaw+bigdft+libxc+wannier90"
#FC=ifort
#CC=icc
FC=mpiifort
CC=mpiicc
#CXX=mpiicc
Please let me know if I misunderstood any of your questions or if you require further information.

User avatar
jbeuken
Posts: 322
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: configure: error: MPI support is broken in CentOS 5.10  [SOLVED]

Post by jbeuken » Wed Apr 22, 2020 12:53 pm

can you try the first test with this ac file

Code: Select all

FC=mpiifort
CC=mpiicc
CXX=mpiicpc

enable_mpi="yes"
enable_mpi_io="yes"

with_linalg_flavor="mkl"
with_linalg_libs="-L${MKLROOT}/lib/intel64 -lmkl_intel_lp64 -lmkl_core -lmkl_sequential -lpthread -lm -ldl"

with_fft_flavor="dfti"
with_fft_libs="-L${MKLROOT}/lib/intel64 -lmkl_intel_lp64 -lmkl_core -lmkl_sequential -lpthread -lm -ldl"

with_dft_flavor="libxc"
------
Jean-Michel Beuken
Computer Scientist

shohams
Posts: 4
Joined: Mon Apr 06, 2020 2:01 am
Location: Pittsburgh, PA

Re: configure: error: MPI support is broken in CentOS 5.10

Post by shohams » Mon Apr 27, 2020 7:10 pm

This got rid of my make error, Thank you. I can make the whole file so I will accept this answer. However, I am getting other errors, so I think I will try to solve it myself and if I don't succeed, I'll start a different post.

Post Reply