Page 1 of 1

homebrew install won't run full test suite option

Posted: Mon Dec 16, 2019 6:22 pm
by outerplanets
Hi there,
New to ABINIT and slightly less new to Homebrew, although I've used it to install other computational codes on my Mac. I ran into trouble trying to run the python program after installing 8.10.3 ABINIT via Homebrew:

Traceback (most recent call last):
File "../share/tests/", line 679, in <module>
File "../share/tests/", line 379, in main
build_env = BuildEnvironment(build_dir_path)
File "/usr/local/Cellar/abinit/8.10.3/share/tests/pymods/", line 988, in __init__
build_dir = find_top_build_tree(build_dir)
File "/usr/local/Cellar/abinit/8.10.3/share/tests/pymods/", line 814, in find_top_build_tree
raise RuntimeError("Cannot find the ABINIT build tree after %s trials" % ntrials)
RuntimeError: Cannot find the ABINIT build tree after 10 trials

I'm wondering if I need to modify the code somewhere, as it's not pointing to the right place for the ABINIT executable? The Homebrew test log indicated that all of the built-in and fast tests passed, but I'd like to run all the tests just to be sure.

I tried to work around the problem by uninstalling and then attempting to reinstall ABINIT via Homebrew using the --with-testsuite option, but then I get the following error message:

Error: An exception occurred within a child process:
ChecksumMismatchError: SHA256 mismatch
Expected: ede1f6b5ab75c94fe29084443d245f1d934d896d0ac64825ef3a15214f83a7f9
Actual: 2674119e0aaea6f5e2f4f95aea8c056d9f0d0606d5f0f3a03401a5c435b8d078
Archive: /Users/ehofmann/Library/Caches/Homebrew/downloads/049b39673b06dfc6836eb9a7463691364d58fded5a3a352ebadd6021e501fcb8--libxc_3to4_patch.diff
To retry an incomplete download, remove the file above.

Removed the file, tried again, same error message. I saw a similar problem (for a different reason) in a much older post, and it seemed the underlying problem was in homebrew-science. I guess I would have expected that that was solved by 8.10.3, so I'm wondering what I might be doing wrong.

Any help would be greatly appreciated!

Re: homebrew install won't run full test suite option

Posted: Fri Dec 20, 2019 10:41 am
by torrent
Dear Outerplanets,

To analyse the problem, we need more information :
- how did you install abinit via homebrew (using homebrew-science or the new formula provided on abinit github?)
- what did you exactly type to lauch the script?, from which directory?
- did you use "brew clean abinit"?

Re: homebrew install won't run full test suite option

Posted: Sun Dec 22, 2019 4:41 pm
by torrent
I was able to reproduce the issue.

A new version of the homebrew formula is now available.
If you use the bottle, a wrapper to the runtests script will be installed.
If you recompile from scratch, you have to use the -with-testsuite option.

You'll be able to run the test suite with the 'ABINIT-runtests' scripts.
Just type 'abinit-runtests --help' to learn more.

Note that some libXC tests will fail because the references files have been generated with libXC v3.

Hope this helps...