abinit-8.8.4 under Windows 10

HPC, IBM, Mac OS, Windows, ...

Moderators: jbeuken, Jordan, gmatteo

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit builds.
For a video explanation on how to build Abinit for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green button on its upper-right corner to accept it.
Post Reply
Posts: 7
Joined: Sat Sep 15, 2018 7:08 pm
Location: Kalpakkam, India

abinit-8.8.4 under Windows 10

Post by rajaraman » Thu Sep 27, 2018 7:46 pm

Here is the successful install of abinit-8.8.4 under Windows 10

Ubuntu linux install

go to Programs & features > turn windows features on or off
activate the "windows subsytem for linux"

from microsoft store
install ubuntu 18.04 app

ubuntu bash window allows all command line operations.
local hard disks are already mounted

no GUI.
but there are work arounds discussed in internet

nano & VIM work fine

If you are behind proxy
proxy config for apt

edit apt.conf
nano /etc/apt/apt.conf

Add this line with your user id and password

Acquire::http::Proxy "http://username:password@proxy.xxxx.yy:portno";

sudo apt-get update
sudo apt-get install make
sudo apt-get install python
sudo apt-get install gfortran
sudo apt-get install libatlas-base-dev liblapack-dev libblas-dev
sudo apt-get install libfftw3

sudo apt-get update
sudo apt-get install openmpi-bin
sudo apt-get install openmpi-common
sudo apt-get install libopenmpi2
sudo apt-get install libopenmpi-dev

(some installs may be redundant. but no harm)

Download tar file and do usual install

for abinit parallel, this config worked (but it did not install atompaw even with fallback option. anyway it can be compiled later for generating PAW potentials)

../configure --with-dft-flavor="libxc+atompaw" --enable-mpi FC=/usr/bin/mpif90 CC=/usr/bin/mpif90 --with-mpi-incs="-I/usr/include" --with-mpi-libs="-L/usr/lib -lmpi"
make mj4
make check
sudo make install


Posts: 26
Joined: Fri Jan 25, 2013 4:00 pm

Re: abinit-8.8.4 under Windows 10

Post by letuan » Wed Nov 07, 2018 5:32 pm

Sorry, I am a new on Ubuntu.
What do you mean under xxxx.yy for proxy in the command phrase [Acquire::http::Proxy "http://username:password@proxy.xxxx.yy:portno";] ?

Thank you, Rajaraman.
Le Tuan,
Dept. of Electronic Materials,
Hanoi Uni. of Sci. and Technol., Vietnam

Posts: 26
Joined: Fri Jan 25, 2013 4:00 pm

Re: abinit-8.8.4 under Windows 10

Post by letuan » Sun Nov 11, 2018 3:49 am

After repeating Rajaraman's receipt, I have stopped by the error as described in viewtopic.php?f=3&t=3956 with Ubuntu 18.04 LTS on Windows 10 64-bit. The effort with abinit-8.8.4 gave the same result.

Then I have switched on SuSE Leap 42.2. (for SuSE Enterprise Server 12 I could not update wth packages), adding the reposirories for upgrading into 42.3 version:

Code: Select all

zypper ar http://download.opensuse.org/distribution/leap/42.3/repo/oss/ 42_3-OSS
zypper ar http://download.opensuse.org/update/leap/42.2/oss/ 42_3-Update

Using zypper command, the SuSE packages, needed for Abinit and phonopy packages, such as gfortran, c++, fftw3. openmpi, scalapack, lapack, blas, atlas, yaml, has been installed, similarly as in Rajaraman's receipt.

For Abinit-8.10.1, the following configuration options are in use (with GNU compilers):

Code: Select all

./configure --with-dft-flavor="libxc+atompaw+wannier90" --enable-mpi --enable-mpi-io="yes" FC=/usr/lib64/mpi/gcc/openmpi/bin/mpif90 CC=/usr/lib64/mpi/gcc/openmpi/bin/mpicc CXX=/usr/lib64/mpi/gcc/openmpi/bin/mpic++ --with-mpi-incs="-I/usr/lib64/mpi/gcc/openmpi/include" --with-mpi-libs="-L/usr/lib64/mpi/gcc/openmpi/lib64 -lmpi" --with-fft-incs="-I/usr/include" --with-fft-libs="-L/usr/lib64 -lfftw3l" --with-math-flavor="none" --enable-optim="aggressive" --with-trio-flavor="netcdf" --with-enable-64bit-flags="yes"

Then compilation went smoothly, with 0 error in testing stage ( the option --with-math-flavor="gsl" gave an error messsage in compilation in the 98_main module, with annadb)

Code: Select all

make mj4
cd ./tests
./runtests.py -j 4 fast

Results should be:
[fast][t29][np=1]: succeeded [file=t29o_TIM8_GEO]
Suite failed passed succeeded skipped disabled run_etime tot_etime
fast 0 2 9 0 0 158.77 167.59
Completed in 89.42 [s]. Average time for test=14.43 [s], stdev=21.57 [s]
Summary: failed=0, succeeded=9, passed=2, skipped=0, disabled=0
Execution completed.
Results in HTML format are available in Test_suite/suite_report.html

Code: Select all

./runtests.py paral -n 2 -j 2
sudo make install
Le Tuan,
Dept. of Electronic Materials,
Hanoi Uni. of Sci. and Technol., Vietnam

Post Reply