MPI support broken error while configuring abinit-7.8.2.

HPC, IBM, Mac OS, Windows, ...

Moderators: jbeuken, gmatteo, Jordan

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit builds.
For a video explanation on how to build Abinit for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green button on its upper-right corner to accept it.

MPI support broken error while configuring abinit-7.8.2.

Postby manik » Wed Nov 16, 2016 7:31 pm

Dear all

I am trying to install abinit-7.8.2 in a cluster environment.

While configuring it, the following error is coming:

checking whether to enable OpenMP support... no
checking whether to build MPI code... yes
checking whether the C compiler supports MPI... no
checking whether the C++ compiler supports MPI... no
checking whether the Fortran Compiler supports MPI... yes
checking whether MPI is usable... no
configure: error: MPI support is broken - please fix your config parameters and/or MPI installation.

My .ac file looks like this:
Code: Select all
prefix="/usr/local"
enable_mpi="yes"
enable_mpi_io="yes"
with_mpi_prefix="/opt/openmpi"
#FC="/opt/openmpi/bin/mpif90"
#CC="/opt/openmpi/bin/mpicc"
#CXX="/opt/openmpi/bin/mpic++"
with_trio_flavor="netcdf+etsf_io"
with_netcdf_incs="-I/usr/include"
with_netcdf_libs="-L/usr/lib -lnetcdf -lnetcdff"
with_fft_flavor="fftw3"
with_fft_incs="-I/usr/include/"
with_fft_libs="-L/usr/lib/x86-64-linux-gnu/ -lfftw3 -lfftw3f"
with_linalg_flavor="atlas"
with_linalg_libs="-L/usr/lib64 -llapack -lf77blas -lcblas -latlas"
#with_dft_flavor="atompaw+libxc"
with_dft_flavor="atompaw+bigdft+libxc+wannier90"


Also the config.log file is attached here:

config.log
log file
(162.24 KiB) Downloaded 379 times


Please help!!
manik
 
Posts: 6
Joined: Wed Nov 16, 2016 10:04 am

Re: MPI support broken error while configuring abinit-7.8.2.

Postby manik » Thu Nov 17, 2016 9:04 am

Can anybody help me.?
manik
 
Posts: 6
Joined: Wed Nov 16, 2016 10:04 am

Re: MPI support broken error while configuring abinit-7.8.2.

Postby pouillon » Thu Nov 24, 2016 1:15 pm

You are using a prehistoric 4.1 version of GCC. Please upgrade your compilers to at least version 4.8.
Yann Pouillon
Simune Atomistics
Donostia-San Sebastián, Spain
User avatar
pouillon
 
Posts: 645
Joined: Wed Aug 19, 2009 10:08 am
Location: Spain

Re: MPI support broken error while configuring abinit-7.8.2.

Postby manik » Fri Nov 25, 2016 10:08 am

Thank you pouillon for your reply. I will try upgrading the compilers.
manik
 
Posts: 6
Joined: Wed Nov 16, 2016 10:04 am


Return to Platform specific questions

Who is online

Users browsing this forum: No registered users and 1 guest

cron