problem with configuring Abinit with libXC on MacOs

HPC, IBM, Mac OS, Windows, ...

Moderators: jbeuken, gmatteo, Jordan

Forum rules
Please have a look at ~abinit/doc/config/build-config.ac in the source package for detailed and up-to-date information about the configuration of Abinit builds.
For a video explanation on how to build Abinit for Linux, please go to: http://www.youtube.com/watch?v=DppLQ-KQA68.
IMPORTANT: when an answer solves your problem, please check the little green button on its upper-right corner to accept it.

problem with configuring Abinit with libXC on MacOs

Postby marchal » Mon Oct 10, 2016 3:06 pm

Dear all,

I am quite new in the abinit community and try to install abinit on MacOsX (Mavericks).
I would like to install it with libXC support, intel fortran compiler and GCC.

After compiling LibXC, I tried to first configure Abinit8.0.8 with the following commang:
../configure --prefix=/Users/adminclient/compile/abinit/abinit-8.0.8/build FC=/opt/app/darwin-x86/exec-mavericks/openmpi/openmpi-1.8.2-ifort/bin/mpif90 CC=/opt/app/darwin-x86/exec-mavericks/openmpi/openmpi-1.8.2-ifort/bin/mpicc FCFLAGS_EXTRA="-ffree-line-length-none" --enable-mpi --enable-mpi-io --with-dft-flavor="libxc" --with-libxc-incs=-I/Users/adminclient/compile/abinit/libxc-2.2.2/include --with-libxc-libs="-L/Users/adminclient/compile/abinit/libxc-2.2.2/lib -lxc -lxcf90"

and I get the following error:
configure: WARNING: package: libxc - preq= - working=no - incs=-I/Users/adminclient/compile/abinit/libxc-2.2.2/include libs=-L/Users/adminclient/compile/abinit/libxc-2.2.2/lib -lxc -lxcf90

+--------------------------------------------------------------+
| Connector detection failure |
+--------------------------------------------------------------+
| The build system of Abinit has not been able to detect |
| one or more requested external packages, probably because |
| you did not provide sufficient information. This means |
| that the build cannot proceed, and the configure script |
| will thus abort now with an error. |
| |
| To address this issue, you may: |
| |
| * make sure that the prerequisites of the external |
| packages are available and enabled, e.g. |
| --with-dft-flavor="libxc+bigdft" or |
| --with-trio-flavor="netcdf+etsf_io" |
| |
| * use the --with-*-bins, --with-*-incs, and |
| --with-*-libs options of configure to provide |
| additional information; please see the section related |
| to connectors in |
| ~abinit/doc/build/config-template.ac for available |
| options and details; |
| |
| * disable the corresponding extensions, by using the |
| associated --with-*-flavor="none" options of |
| configure; please see the section associated to |
| connectors in ~abinit/doc/build/config-template.ac for |
| details. |
| |
+--------------------------------------------------------------+

configure: error: external libxc support does not work

You will find attached the config.log

Can anyone help me please

Thanks

Rémi
Attachments
config.log
(136.68 KiB) Downloaded 175 times
Last edited by marchal on Wed Oct 12, 2016 4:36 pm, edited 1 time in total.
marchal
 
Posts: 4
Joined: Fri Oct 07, 2016 7:49 am

Re: problem with configuring Abinit with libXC on MacOs

Postby snow » Wed Oct 12, 2016 2:03 am

Hi Marchal,

I have a very similar problem but not on MacOS, and I suspect MacOS is unrelated. Looks like maybe a config problem with the libxc compile, but I don't know, I'm stuck on the same problem. Here's my thread:
viewtopic.php?f=2&t=3389#p10340

Let me know if you figure anything out. And good luck

-Ryan
snow
 
Posts: 7
Joined: Fri Aug 07, 2015 6:53 pm

Re: problem with configuring Abinit with libXC on MacOs

Postby pouillon » Thu Nov 24, 2016 1:11 pm

Mac OS is a bit picky about library order. Just reverse "-lxc -lxcf90" to "-lxcf90 -lxc" and it should work.
Yann Pouillon
Simune Atomistics
Donostia-San Sebastián, Spain
User avatar
pouillon
 
Posts: 645
Joined: Wed Aug 19, 2009 10:08 am
Location: Spain


Return to Platform specific questions

Who is online

Users browsing this forum: No registered users and 2 guests