confugure fails with Intel ifort 19 compiler

Moderator: pouillon

Post Reply
Paul Kapinos
Posts: 4
Joined: Mon Jan 07, 2019 6:59 pm

confugure fails with Intel ifort 19 compiler

Post by Paul Kapinos » Mon Jan 07, 2019 7:08 pm

Dear Developer,
we got this error when trying to compile abilit 8.10.1 using Intel(R) Fortran Intel(R) 64 Compiler for applications running on Intel(R) 64, Version 19.0.1.144 Build 20181018:
> checking whether the Fortran compiler provides the iso_c_binding module... configure: error: Fortran compiler does not provide iso_c_binding module. Use a more recent version or a different compiler

Looking into configure.log we see the below text: conftest.F90 failed to be compiled.

The root of the issue is also here:
> ifort: command line error: option '-openmp' is not supported. Please use the replacement option '-qopenmp'
Note that Intel changed their command line syntax for OpenMP support quite a while ago from '-openmp' to '-qopenmp'. In version 19, the use of the old command line parameter became an error instead of warning.

Obviouly, the solution would be to use '-qopenmp' flag in the configuire step for Intel [19 an later] compilers; at this point I would give the control to the ABINIT developers.

Have a nice day,
Paul Kapinos

configure:21189: checking whether the Fortran compiler provides the iso_c_binding module
configure:21211: mpiifort -o conftest -g -extend-source -vec-report0 -noaltparam -nofpscomp -openmp conftest.F90 >&5
ifort: command line remark #10148: option '-vec-report0' not supported
ifort: command line error: option '-openmp' is not supported. Please use the replacement option '-qopenmp'
configure:21211: $? = 1
configure: failed program was:
| program main
|
| use iso_c_binding
| implicit none
| integer(c_int) :: ii
| logical :: lbool
| type(c_ptr) :: ptr
| ptr = c_null_ptr
| lbool = c_associated(ptr)
|
|
| end
configure:21228: error: Fortran compiler does not provide iso_c_binding module. Use a more recent version or a different compiler



$ mpiifort -o conftest -g -extend-source -vec-report0 -noaltparam -nofpscomp -openmp conftest.F90
ifort: command line remark #10148: option '-vec-report0' not supported
ifort: command line error: option '-openmp' is not supported. Please use the replacement option '-qopenmp'
$ echo $?
1
$ mpiifort -o conftest -g -extend-source -vec-report0 -noaltparam -nofpscomp -qopenmp conftest.F90
ifort: command line remark #10148: option '-vec-report0' not supported
pk224850@login18-1:/w0/tmp/pk224850[508]$ echo $?
0

Paul Kapinos
Posts: 4
Joined: Mon Jan 07, 2019 6:59 pm

Re: confugure fails with Intel ifort 19 compiler

Post by Paul Kapinos » Mon Jan 07, 2019 7:38 pm

... tried to set
$ ./configure .................FCFLAGS_OPENMP=-qopenmp
with no change in the behaviour => unable to build using ifort 19.

Paul Kapinos
Posts: 4
Joined: Mon Jan 07, 2019 6:59 pm

Re: confugure fails with Intel ifort 19 compiler

Post by Paul Kapinos » Mon Jan 07, 2019 7:52 pm

looking into './configure' script just for curious show:
- there are code blocks for 'intel' compilers 15.0) 17.0) 16.0) 18.0) (in that order) but no branch for 19.0) so it fails back to the defauil one which has the obsolete '-openmp' flag.

=> could you add 19.0) branch in configure?

Meanwhile trying to build it after renaming 18.0 to 19.0, let's see what happen'..

Paul Kapinos
Posts: 4
Joined: Mon Jan 07, 2019 6:59 pm

Re: confugure fails with Intel ifort 19 compiler

Post by Paul Kapinos » Tue Jan 08, 2019 3:26 pm

also note that the below message in configre log, with Intel Fortran compiler 9.1 as example, is a bit dusty today :-)

+--------------------------------------------------------------+
| About the Intel Fortran compiler |
+--------------------------------------------------------------+
| Your compiler will work properly only if the LD_LIBRARY_PATH |
| and INTEL_LICENSE_FILE environment variables are correctly |
| set-up. Please make sure that this is the case before |
| building ABINIT. |
| |
| In most cases it means sourcing a script in the Intel |
| compiler install directory, e.g.: |
| |
| . /opt/intel/fc/9.1/bin/ifortvars.sh |
| |
| for a Bourne-like shell (do not forget the leading dot), or |
| |
| source /opt/intel/fc/9.1/bin/ifortvars.csh |
| |
| for a C-like shell. |
| |
| If you do not know what this is all about, please refer to |
| the Intel documentation or ask your system administrator. |
| |
| Please note that the same holds for the Intel C and C++ |
| compilers. |
+--------------------------------------------------------------+

User avatar
pouillon
Posts: 651
Joined: Wed Aug 19, 2009 10:08 am
Location: Spain
Contact:

Re: configure fails with Intel ifort 19 compiler

Post by pouillon » Sun Jan 13, 2019 10:33 pm

I'll fix this ASAP. This will be released in the next version of ABINIT.

In the meantime, if you have the Autotools installed on your system, you can edit the following files:

* config/hints/cc_intel_default-hints.conf
* config/hints/fc_intel_default-hints.conf

and run config/scripts/makemake before trying to build ABINIT again.
Yann Pouillon
Simune Atomistics
Donostia-San Sebastián, Spain

Post Reply