POWER8 Compatibility: Update config.guess

Moderator: pouillon

Post Reply
jlost
Posts: 4
Joined: Tue Aug 30, 2016 10:01 pm

POWER8 Compatibility: Update config.guess

Post by jlost » Tue Aug 30, 2016 10:19 pm

I noticed config.guess is very out of date in several places in your codebase. This is an obstacle to compiling on POWER8 systems, forcing a manual override. If the config.guess is updated to the latest version in all locations, it will detect the correct architecture.

All locations of config.guess:

Code: Select all

[u0017592@sys-82824 abinit-8.0.8]$ find . -name "*.guess"
./tests/config/gnu/config.guess
./doc/config/gnu/config.guess
./bindings/config/gnu/config.guess
./config/gnu/config.guess
./fallbacks/config/gnu/config.guess


Error example:

Code: Select all

=== configuring in fallbacks (/home/u0017592/projects/abinit-8.0.8/fallbacks)
configure: running /bin/sh ./configure --disable-option-checking '--prefix=/usr/local'  '--enable-atompaw=no' '--enable-bigdft=no' '--enable-etsf-io=no' '--enable-libxc=no' '--enable-linalg=yes' '--enable-netcdf=no' '--enable-wannier90=no' '--with-fc-vendor=gnu' '--with-fc-version=4.8' '--with-tardir=/home/u0017592/.abinit/tarballs' --cache-file=/dev/null --srcdir=.
checking build system type... config/gnu/config.guess: unable to guess system type

This script, last modified 2009-11-20, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from

  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
and
  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD

If the version you run (config/gnu/config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <config-patches@gnu.org> in order to provide the needed
information to handle your system.

config.guess timestamp = 2009-11-20

uname -m = ppc64le
uname -r = 3.10.0-229.ael7b.ppc64le
uname -s = Linux
uname -v = #1 SMP Fri Jan 30 12:03:50 EST 2015

/usr/bin/uname -p = ppc64le
/bin/uname -X     =

hostinfo               =
/bin/universe          =
/usr/bin/arch -k       =
/bin/arch              = ppc64le
/usr/bin/oslevel       =
/usr/convex/getsysinfo =

UNAME_MACHINE = ppc64le
UNAME_RELEASE = 3.10.0-229.ael7b.ppc64le
UNAME_SYSTEM  = Linux
UNAME_VERSION = #1 SMP Fri Jan 30 12:03:50 EST 2015
configure: error: cannot guess build type; you must specify one
configure: error: ./configure failed for fallbacks

User avatar
pouillon
Posts: 651
Joined: Wed Aug 19, 2009 10:08 am
Location: Spain
Contact:

Re: POWER8 Compatibility: Update config.guess

Post by pouillon » Tue Sep 13, 2016 3:49 pm

There has obviously been a mistake when generating the source tarball, with the use of an outdated version of the Autotools. We will take care of generating the future releases of all Abinit components with an up-to-date development environment.

In the meantime, since you are not using any optional feature, I strongly recommend you to use IBM's optimized linear algebra libraries (--with-linalg-flavor="essl"), since using Abinit's internal library on a Power8 implies a huge loss of performance. This way, even if the configure script of the fallbacks fails, you should still be able to build and run Abinit.
Yann Pouillon
Simune Atomistics
Donostia-San Sebastián, Spain

Post Reply