abinit-7.8.2 makemake error  [SOLVED]

Moderator: pouillon

Post Reply
abokhanc
Posts: 24
Joined: Tue Jul 29, 2014 4:28 pm

abinit-7.8.2 makemake error

Post by abokhanc » Thu Sep 25, 2014 6:26 pm

Hi,

When i run makemake script i get the following error:

[makemake] ---> running ./config/scripts/abilint --dependencies --dump_dtset bindings/parser/dtset.pickle . . 1>abilint.out 2>&1
[makemake] Generating dtset source files
[makemake] === Synchronization of subsystems ===
[makemake] Wiping out former file lists for subsystems
[makemake] Sluicing out the tests subsystem (subdir: tests)
sh: ./wipeout.sh: No such file or directory
[makemake] Aborting now!

Can anyone direct me where i could get this wipeout.sh file?

Thank you

User avatar
pouillon
Posts: 651
Joined: Wed Aug 19, 2009 10:08 am
Location: Spain
Contact:

Re: abinit-7.8.2 makemake error  [SOLVED]

Post by pouillon » Mon Oct 06, 2014 11:57 am

Thank you for reporting this issue.

The wipeout.sh scripts were only available from Abinit development branches and not distributed with the source tarball up to now, since makemake is exclusively a developer tool.

I fixed this in the upcoming Abinit 7.10 build system, in order to allow external contributors to use makemake. Further fixes have been deferred to Abinit 8.0.

If you wish to contribute to Abinit, the best is however that you discuss directly with Xavier Gonze and get a development branch.
Yann Pouillon
Simune Atomistics
Donostia-San Sebastián, Spain

Post Reply