Problem with module etsf_io  [SOLVED]

Moderator: pouillon

Post Reply
User avatar
sponce
Posts: 60
Joined: Sat Apr 16, 2011 9:44 am

Problem with module etsf_io

Post by sponce » Tue May 06, 2014 5:18 pm

Dear Developper,

I have created a new module "m_eig2d.F90" in src/72_response

In that module I have

Code: Select all

#ifdef HAVE_TRIO_ETSF_IO
 use etsf_io
#endif


when compiling on woopy I get a Fatal error :

Code: Select all

/usr/local/mpich_gcc/bin/mpif90 -DHAVE_CONFIG_H -I. -I../.. -I../../src/incs -I../../src/incs -I/home/buildbot/ABINIT/woopy_gcc48/sponce_7.7.3-public/fallbacks/exports/include   -ffree-form -J/home/buildbot/ABINIT/woopy_gcc48/sponce_7.7.3-public/src/mods  -O2 -mtune=native -march=native -ffree-line-length-none   -c -o m_eig2d.o m_eig2d.F90
m_eig2d.F90:36.5:

 use etsf_io
     1
Fatal Error: Can't open module file 'etsf_io.mod' for reading at (1): No such file or directory


The problem is that there is a line missing in the Makefile line.
Indeed the same use etsf_io in 62_occeig/m_ebands.F90 work:

Code: Select all

/usr/local/mpich_gcc/bin/mpif90 -DHAVE_CONFIG_H -I. -I../.. -I../../src/incs -I../../src/incs -I/usr/local/bigdft/include -I/usr/local/fallbacks-dev/include -I/usr/include -I/home/buildbot/ABINIT/woopy_gcc48/sponce_7.7.3-public/fallbacks/exports/include   -ffree-form -J/home/buildbot/ABINIT/woopy_gcc48/sponce_7.7.3-public/src/mods  -O2 -mtune=native -march=native -ffree-line-length-none   -c -o m_ebands.o m_ebands.F90


What should I do in order to modify the Makefile and to add the correct call to etsf_io lib -I/usr/local/fallbacks-dev/include ?

Cheers !

Samuel

User avatar
pouillon
Posts: 651
Joined: Wed Aug 19, 2009 10:08 am
Location: Spain
Contact:

Re: Problem with module etsf_io  [SOLVED]

Post by pouillon » Tue May 06, 2014 7:02 pm

You have to explicitely declare all dependencies in config/specs/corelibs.conf for now. Please check that the dependency on etsf_io is properly set for the directories you're working in.

This will change in the future, as soon as the information provided by abilint is fully exported to and exploited by the build system. Thank you in advance for your patience.
Yann Pouillon
Simune Atomistics
Donostia-San Sebastián, Spain

User avatar
sponce
Posts: 60
Joined: Sat Apr 16, 2011 9:44 am

Re: Problem with module etsf_io

Post by sponce » Thu May 08, 2014 10:54 am

Oh I see. Thank you for the reply Yann.

There is no problem with having to do that.

I indeed though that I had to do something like that but could not find the information on doc/developers. Is that information written somewhere?

Kind Regards,

Samuel.

Post Reply