MPI level = 3 fails

Moderator: pouillon

Post Reply
zeroth
Posts: 12
Joined: Fri Jan 24, 2014 5:12 pm

MPI level = 3 fails

Post by zeroth » Wed Nov 18, 2020 10:13 am

When trying to use MPI level 3 (--with-mpi-level=3) the build crashes.

The reason is quite simple,

Look at shared/common/src/11_memory_mpi/m_profiling_abi.F90

There you have:
#ifdef HAVE_MPI2
use mpi
#endif
...
#if defined HAVE_MPI1
include 'mpif.h'
#endif


but no where do you have HAVE_MPI3.
This results in undefined variables (MPI_COMM_WORLD etc.)

Oh, and this is for v9.2.1 and v9.2.2 (sorry)
/ Nick Papior

Post Reply