Make fails due to automake version

Moderator: pouillon

Post Reply
BaconEgg
Posts: 1
Joined: Thu Apr 30, 2020 5:14 pm

Make fails due to automake version

Post by BaconEgg » Thu Apr 30, 2020 6:58 pm

I'm trying to compile on a remote cluster and ./configure comes back clean, but running make -d gives

Code: Select all

...
Considering target file `Makefile'.
   Considering target file `Makefile.in'.
     Considering target file `Makefile.am'.
      Looking for an implicit rule for `Makefile.am'.
      Trying pattern rule with stem `Makefile.am'.
      Trying implicit prerequisite `Makefile.am,v'.
      Trying pattern rule with stem `Makefile.am'.
      Trying implicit prerequisite `RCS/Makefile.am,v'.
      Trying pattern rule with stem `Makefile.am'.
      Trying implicit prerequisite `RCS/Makefile.am'.
      Trying pattern rule with stem `Makefile.am'.
      Trying implicit prerequisite `s.Makefile.am'.
      Trying pattern rule with stem `Makefile.am'.
      Trying implicit prerequisite `SCCS/s.Makefile.am'.
      No implicit rule found for `Makefile.am'.
      Finished prerequisites of target file `Makefile.am'.
     No need to remake target `Makefile.am'.
...
    Prerequisite `aclocal.m4' is newer than target `Makefile.in'.
   Must remake target `Makefile.in'.
Invoking recipe from Makefile:424 to update target `Makefile.in'.
make[1]: Entering directory `/home/username/abinit-8.10.3/fallbacks'
Putting child 0x16ba180 (Makefile.in) PID 225284 on the chain.
Live child 0x16ba180 (Makefile.in) PID 225284 
 cd . && /bin/sh /home/username/abinit-8.10.3/fallbacks/config/gnu/missing automake-1.16 --gnu
/home/username/abinit-8.10.3/fallbacks/config/gnu/missing: line 81: automake-1.16: command not found
WARNING: 'automake-1.16' is missing on your system.
         You should only need it if you modified 'Makefile.am' or
         'configure.ac' or m4 files included by 'configure.ac'.
         The 'automake' program is part of the GNU Automake package:
         <https://www.gnu.org/software/automake>
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:
         <https://www.gnu.org/software/autoconf>
         <https://www.gnu.org/software/m4/>
         <https://www.perl.org/>
I get the same problem with abinit 8.10.3 and 9.0.3. The cluster has automake 1.13.4 but I don't have a way to change the version. Everything compiles fine on my mac, which does not have automake. Running ./autogen.sh gives a fatal error that abisrc.py is not found, which indeed I don't see abisrc.py in /src. Running automake and aclocal on the cluster didn't help. Not sure how to proceed. Should I be looking for a way to ignore the available automake?

User avatar
jbeuken
Posts: 340
Joined: Tue Aug 18, 2009 9:24 pm
Contact:

Re: Make fails due to automake version

Post by jbeuken » Sat Jun 27, 2020 10:04 am

Hi,

Code: Select all

wget https://www.abinit.org/sites/default/files/packages/abinit-8.10.3.tar.gz
tar xzf abinit-8.10.3.tar.gz
cd abinit-8.10.3/
./configure
make -j 12
works for me...

where did you find the tarball?
------
Jean-Michel Beuken
Computer Scientist

Post Reply