8.8.2: m_pawxc.F90 build error

Moderator: pouillon

8.8.2: m_pawxc.F90 build error

Postby xyne » Sun Jun 03, 2018 9:24 pm

Hi, I am the maintainer of the abinit package on Arch Linux and I am currently trying to update from 8.6.3 to 8.8.2 but the compilation fails with the following error (idem with 8.8.1):
Code: Select all
m_pawxc.F90:1105:15:

        mag_ => rhonow(1:nrad,2:4,1)
               1
Error: Assignment to contiguous pointer from non-contiguous target at (1)
make[3]: *** [Makefile:989: m_pawxc.o] Error 1


System information:
  • linux 4.16.13-1-ARCH
  • gcc fortran 8.1.0
  • atompaw 4.1.0.1
  • openblas 0.3.0 (provides blas 3.8.0), also tested with blas 3.8.0
  • lapack 3.8.0
  • openmpi 3.1.0
I am not familiar enough with Fortran to debug this myself. Does anyone have any suggestions of how to fix this? Please let me know if you require more information. Thanks in advance for any help.

Regards,
Xyne
xyne
 
Posts: 2
Joined: Sun Jun 03, 2018 8:24 pm

Re: 8.8.2: m_pawxc.F90 build error

Postby pouillon » Fri Jun 08, 2018 10:51 am

FYI: The bugfix for this problem is currently in the pipes and will be made available with ABINIT 8.8.3. Thank you for your patience.

A temporary measure could be to rebuild ABINIT with an older version of GCC.
Yann Pouillon
Universidad de Cantabria
Santander, Spain
User avatar
pouillon
 
Posts: 641
Joined: Wed Aug 19, 2009 10:08 am
Location: Spain

Re: 8.8.2: m_pawxc.F90 build error

Postby xyne » Fri Jun 29, 2018 2:37 am

Thank you for the reply and the suggestion. The error appears to indeed be resolved with 8.8.3.
xyne
 
Posts: 2
Joined: Sun Jun 03, 2018 8:24 pm


Return to Build system

Who is online

Users browsing this forum: No registered users and 1 guest

cron