Error occurs in 7.10.5, when using fftw3.3.4 and cuda 7.5  [SOLVED]

External optional components of Abinit (BigDFT, Wannier90, ...) and codes using / providing data from / to Abinit (AtomPAW, EXC, DP, SAX, WanT, Yambo, ...).

Moderator: rangel

Post Reply
kinsang
Posts: 13
Joined: Wed Mar 23, 2016 2:24 pm

Error occurs in 7.10.5, when using fftw3.3.4 and cuda 7.5

Post by kinsang » Wed Mar 23, 2016 2:36 pm

Hi, everyone.
I am a new user to abinit.
I successfully compiled abinit with fftw3.3.4 and cuda 7.5, as well as MPI support.
When I ran the test in abinit7-10-5/tests/tutoparal/Input/tdfpt_01.files, an error occured as follows.

configure.ac:
# configure file
FC=mpiifort
CC=mpiicc
CXX=mpiicpc
enable_mpi="yes"
enable_mpi_io="yes"
# enable_gpu="yes"
# with_gpu_flavor="cuda-double"
# with_gpu_prefix="/usr/local/cuda-7.5"
enable_debug="no"
enable_optim="yes"
enable_hints="yes"
FCFLAGS_OPTIM="-xHost -w -O2"
CFLAGS_OPTIM="-xHost -w -O2"
CFLAGS="-O2 -xHost"

enable_fallbacks="no"

# linalg
with_linalg_flavor="mkl"
with_linalg_incs="-I/opt/intel/ICC2016/mkl/include"
with_linalg_libs="-L/opt/intel/ICC2016/mkl/lib/intel64 -lmkl_intel_lp64 -lmkl_core -lmkl_sequential"

# fftw
with_fft_flavor="fftw3-threads"
with_fft_incs="-I/home/kinsang/INSTALL/intel/fftw334/include"
with_fft_libs="-L/home/kinsang/INSTALL/intel/fftw334/lib -lfftw3f_threads"

Input variables:

# FCC Al; 10 special points

#timopt -1

acell 3*7.56
densty 1.2
ecut 10

enunit 2

localrdwf 1
ngkpt 8 8 8
nshiftk 4
shiftk 0.5 0.5 0.5
0.5 0.0 0.0
0.0 0.5 0.0
0.0 0.0 0.5

natom 1 nband 5
nline 3 nstep 20
ntypat 1
occopt 4 prtden 1 prtvol 10
rprim 0 .5 .5 .5 0 .5 .5 .5 0
timopt 2
tnons 72*0.0d0
tolvrs 1.0d-18
typat 1
xred 0.0 0.0 0.0
znucl 13.0

# This line added when defaults were changed (v5.3) to keep the previous, old behaviour
iscf 5
# add to conserve old < 6.7.2 behavior for calculating forces at each SCF step
optforces 1

Log: --- !ERROR
message: |
Checking consistency of input data against itself gave 1 inconsistencies.
src_file: chkinp.F90
src_line: 3000
...
leave_new : decision taken to exit ...

More logs are enclosed.
Pleased help me, thank you!
Attachments
test01.log
The running outputs
(30.7 KiB) Downloaded 215 times

Jordan
Posts: 282
Joined: Tue May 07, 2013 9:47 am

Re: Error occurs in 7.10.5, when using fftw3.3.4 and cuda 7.  [SOLVED]

Post by Jordan » Fri Mar 25, 2016 8:50 am

As far as I remember, there is a small bug in the FFT initialization.
If you have a GPU version of abinit, you should not make any FFT on CPU since it is far more efficient on GPU therefore you should not use fftw3.
If you compile abinit without fftw3 and with cuda it should work.
Try to set fftalg to 112 before recompiling.

This bug is actually not meaningfull. There is just a line where the check is badly done. it should not stop.... Sorry for the inconvenience.

Cheers

PS : Be carefull. you use intel16 and cuda7 which has not been tested (and actually is not even supported). In addition, the GPU version has not been updated for a while.

kinsang
Posts: 13
Joined: Wed Mar 23, 2016 2:24 pm

Re: Error occurs in 7.10.5, when using fftw3.3.4 and cuda 7.

Post by kinsang » Fri Mar 25, 2016 2:12 pm

Jordan wrote:As far as I remember, there is a small bug in the FFT initialization.
If you have a GPU version of abinit, you should not make any FFT on CPU since it is far more efficient on GPU therefore you should not use fftw3.
If you compile abinit without fftw3 and with cuda it should work.
Try to set fftalg to 112 before recompiling.

This bug is actually not meaningfull. There is just a line where the check is badly done. it should not stop.... Sorry for the inconvenience.

Cheers

PS : Be carefull. you use intel16 and cuda7 which has not been tested (and actually is not even supported). In addition, the GPU version has not been updated for a while.


Thank you, Jordan.
I removed fftw3 and it works. I did not know about "fftalg" before what's its effect?
And I still wonder how to choose the libraries to make abinit run fast.
As you know, I disable fallbacks, and now link intel mkl and magma, how to make better configuration.
I would appreciate if you could give me your email, thanks again.

Jordan
Posts: 282
Joined: Tue May 07, 2013 9:47 am

Re: Error occurs in 7.10.5, when using fftw3.3.4 and cuda 7.

Post by Jordan » Tue Apr 05, 2016 11:07 am

Hi.

Using external optimized libraries is the way to go.
Therefore using magma/plasma and MKL is probably one of the best things you can do on an intel CPU and nvidia GPU.

fftalg just change the library used to perform a FFT. abinit can use fftw3, mkl, built-in FFT, ...the result should not depend on this variable, just the speed of the calculation.

Cheers

Jordan

Post Reply