How to interface Abinit with current version of WanT code  [SOLVED]

External optional components of Abinit (BigDFT, Wannier90, ...) and codes using / providing data from / to Abinit (AtomPAW, EXC, DP, SAX, WanT, Yambo, ...).

Moderator: rangel

Post Reply
Seba Darshan
Posts: 63
Joined: Mon Feb 17, 2014 5:19 am

How to interface Abinit with current version of WanT code  [SOLVED]

Post by Seba Darshan » Thu Aug 27, 2015 11:08 am

Dear Abinit users

I have seen in the Abinit website that by setting the input variable "prtwant" to 1, Abinit-WanT interface can be used, where it is also mentioned that 1 corresponds to the version of the WanT (1.0.1). Since the current version of WanT 2.5.0, what value I have to give for "prtwant" to use the Abinit-WanT interface.

As it is also mentioned that "prtwant" value of 2 corresponds to the use of Abinit-Wannier 90, so what I understands is that by using the value of 2, it does not mean the interfacing of WanT 2.5.0 with Abinit.
I would like to know how can I interface the current version of WanT code with Abinit.

It would be of great help if someone who knows this could help me in this regard.

Thanks in Advance
Seba

rangel
Posts: 45
Joined: Tue Aug 18, 2009 9:50 pm

Re: How to interface Abinit with current version of WanT cod

Post by rangel » Tue Dec 01, 2015 6:09 pm

Hi prtwant 1 was to be used with an old version of WanT.

The new ABINIT-WanT interface is inside WanT.
There is a convertor from the WFK ABINIT format to ETSF:
Use it as:
[want]/bin/wfk2etsf.x o_DS1_WFK

This will convert o_DS1_WFK into a wavefunction file in etsf format.

Then in the input of WanT, you should indicate the name of the wavefunction as prefix= 'o_DS1'

An example is in:
[want]/tests/test03

Look for the files named as "_abi"
Tonatiuh Rangel

Post Reply