abipy test error

External optional components of Abinit (BigDFT, Wannier90, ...) and codes using / providing data from / to Abinit (AtomPAW, EXC, DP, SAX, WanT, Yambo, ...).

Moderator: rangel

Post Reply
sheng
Posts: 64
Joined: Fri Apr 11, 2014 3:44 pm

abipy test error

Post by sheng » Mon May 18, 2015 2:26 pm

Hi I have managed to compile abipy from git but I encounter some error when running the tests:

Code: Select all

[root@comsics abipy]# nosetests
EEEEEEEEE...EE....E..EEEEEEE.EEEEEEEEEEEEEE......SSE.....S...EEE............EEEEEEEEEEEEE
======================================================================
ERROR: Failure: ImportError (cannot import name phonon_conv_flow)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/share/apps/estools/python/2.7.9/lib/python2.7/site-packages/nose/loader.py", line 420, in loadTestsFromName
    addr.filename, addr.module)
  File "/share/apps/estools/python/2.7.9/lib/python2.7/site-packages/nose/importer.py", line 47, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/share/apps/estools/python/2.7.9/lib/python2.7/site-packages/nose/importer.py", line 94, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/home/sheng/Desktop/program/Abinit/abipy/abipy/abilab.py", line 13, in <module>
    from pymatgen.io.abinitio.flows import (Flow, G0W0WithQptdmFlow, bandstructure_flow,
ImportError: cannot import name phonon_conv_flow

....


All the tests failed.
I have followed every step provided at the git page.

Another atttempt:

Code: Select all

[sheng@comsics Desktop]$ python
Python 2.7.9 (default, May 14 2015, 15:36:16)
[GCC 4.9.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from abipy.abilab import abiopen
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/share/apps/estools/python/2.7.9/lib/python2.7/site-packages/abipy-0.1.0-py2.7.egg/abipy/abilab.py", line 13, in <module>
    from pymatgen.io.abinitio.flows import (Flow, G0W0WithQptdmFlow, bandstructure_flow,
ImportError: cannot import name phonon_conv_flow


I would appreciate any help. Thank you.

Post Reply