Segmentation fault

Moderators: gmatteo, bruneval, rigna

Post Reply
Bibek Samal
Posts: 4
Joined: Fri Nov 08, 2019 9:52 am

Segmentation fault

Post by Bibek Samal » Fri Nov 08, 2019 10:39 am

Hi, I am using abinit since July. have abinit -8.10.3 which I compiled using both parallel build and without parallel build. For parallel build I used ifort. During compilation all the make tests failed but other parts were okay. Later I started running parallel calculation using this version, all the calculations went well but when I started GW calculation, the calculation is not running after second dataset i.e. the Wavefunction generation one even for the Si input given in the tutorial. The error in the log file tells segmentation fault. Then I made the stack size unlimited but that did not help. Can anyone please tell me the problem?

ebousquet
Posts: 469
Joined: Tue Apr 19, 2011 11:13 am
Location: University of Liege, Belgium

Re: Segmentation fault

Post by ebousquet » Thu Nov 21, 2019 3:35 pm

Dear Bibek Samal,
Segmentation fault are the hardest error message to solve because we have no real clue of the origin, here it sounds when the code reads the WFs, which could be related to a memory problem, how big is your system, ecut and k-point and what is the size of the RAM you have?
Best wishes,
Eric

Bibek Samal
Posts: 4
Joined: Fri Nov 08, 2019 9:52 am

Re: Segmentation fault

Post by Bibek Samal » Thu Nov 28, 2019 9:47 am

Thanks for your reply. By playing with those parameters I have completed the GW calculation successfully.

Post Reply