In repfn calculation, istwfk is supposed to be 1  [SOLVED]

Moderators: mverstra, aromero

Post Reply
tyst3273
Posts: 8
Joined: Fri Jul 17, 2020 12:35 am
Location: Boulder, CO

In repfn calculation, istwfk is supposed to be 1

Post by tyst3273 » Mon Aug 10, 2020 10:07 pm

Hi Abinit users,

I am using Abinit 9.0.4.

(I created another post a few minutes ago for a similar calculation, but I believe that problem is unrelated to this one. I am not double posting to get my problem seen! Sorry if these two issues are related!)


While trying to do a response function calculation, Abinit crashes complaining that istwfk is supposed to be 1 for all kpoints. I don't set this number in the input file and it apparently is supposed to be enforced automatically by Abinit for respfn calculations (the variables webpage says this!).

The code crashes with the following error:

chkinp: Checking input parameters for consistency, jdtset= 1.

--- !ERROR
src_file: m_chkinp.F90
src_line: 1282
mpi_rank: 0
message: |
Only the gamma point can use time-reversal and wfoptalg=4 or 14
Action: put istwfk to 1 or remove k points with half integer coordinates
Also contact ABINIT group to say that you need that option.
...

--- !ERROR
src_file: m_chkinp.F90
src_line: 3665
mpi_rank: 0
message: |
One of the components of istwfk is not equal to 1 or 2.
Time-reversal symmetry is not yet programmed in the case of band-FFT parallelization.
Action: set istwfk to 1 or 2 for all k-points
...

chkinp: Checking input parameters for consistency, jdtset= 2.

--- !ERROR
src_file: m_chkinp.F90
src_line: 3855
mpi_rank: 0
message: |
Checking consistency of input data against itself gave 2 inconsistencies.
The details of the problems can be found above.
...



The q-point is 0.5 0 0.

The input pert.in and gs.in files are attached.

Any help is appreciated!

Thanks a lot,

Ty
Attachments
gs.in
(1.44 KiB) Downloaded 46 times
pert.in
(1.79 KiB) Downloaded 49 times

ebousquet
Posts: 469
Joined: Tue Apr 19, 2011 11:13 am
Location: University of Liege, Belgium

Re: In repfn calculation, istwfk is supposed to be 1

Post by ebousquet » Wed Aug 12, 2020 12:01 pm

Dear Ty,
Strange indeed, what about if you remove the nsppol, nspden and spinat flags since you have no magnetism?
I would also remove completely autoparal flag because the error is associated to the algo used for parallelism and for DFPT paral_kgb is not working. Could you test this and tell us the result?
Otherwise just set istwfk *1 as requested...
Best wishes,
Eric
Last edited by ebousquet on Wed Aug 19, 2020 10:13 am, edited 2 times in total.

tyst3273
Posts: 8
Joined: Fri Jul 17, 2020 12:35 am
Location: Boulder, CO

Re: In repfn calculation, istwfk is supposed to be 1

Post by tyst3273 » Wed Aug 12, 2020 5:09 pm

Hi Eric,
Thanks again for the reply!

I removed autoparal and it runs without crashing (so far, it is still running). nsppol, etc. had no effect.

Apparently the problem occurred during the nscf (k+q) step with autoparal present. I should have noticed and mentioned that istwfk in the .abo file was correct (only 1's and 0's) for the response function dataset (with rfphon=1). It looks like Abinit was complaining about istwfk being wrong in the nscf (with k+q) run (1's, 3's, and 0's is what I saw). Does istwfk need to be only 1's in the nscf run?

Thanks again,
Ty

ebousquet
Posts: 469
Joined: Tue Apr 19, 2011 11:13 am
Location: University of Liege, Belgium

Re: In repfn calculation, istwfk is supposed to be 1

Post by ebousquet » Wed Aug 19, 2020 10:23 am

Hi Ty,
It sounds that at your nscf k+q, you end up with a grid that is not OK with time-reversal symmetry (well, as it is presently implemented). Just setting istwfk*1 or *0 works fine a the end?
Best wishes,
Eric

tyst3273
Posts: 8
Joined: Fri Jul 17, 2020 12:35 am
Location: Boulder, CO

Re: In repfn calculation, istwfk is supposed to be 1

Post by tyst3273 » Tue Aug 25, 2020 5:58 pm

Hi Eric,

I removed autoparal and it solved my problem. I considered this satisfactory and didn't bother setting istwfk.

For troubleshooting purposes, would you like me to try this?

Thanks again,
Ty

ebousquet
Posts: 469
Joined: Tue Apr 19, 2011 11:13 am
Location: University of Liege, Belgium

Re: In repfn calculation, istwfk is supposed to be 1  [SOLVED]

Post by ebousquet » Wed Aug 26, 2020 10:34 am

Hi Ty,
OK, thank you for your response, no need to test istwfk *1 if autoparall worked at the end, I'll keep in mind this potential problem.
Best wishes,
Eric

Post Reply