Search found 339 matches

by jbeuken
Sun Apr 30, 2017 9:27 pm
Forum: Configuration
Topic: compiling triqs [SOLVED]
Replies: 6
Views: 3113

Re: compiling triqs [SOLVED]

Dear jf rivas,

Very glad you managed with openmpi !
When I have a little time, I will try your recipe...

Regards,

jmb
by jbeuken
Mon Apr 24, 2017 10:09 pm
Forum: Configuration
Topic: compiling triqs [SOLVED]
Replies: 6
Views: 3113

Re: compiling triqs [SOLVED]

Hi, make[3]: Entering directory '/home/rivas/Desktop/abinit-8.2.2p/src/01_triqs_ext' /opt/openmpi-1.6.3/bin/mpicxx -std=c++14 -DHAVE_CONFIG_H -I. -I../.. -I../../src/incs -I../../src/incs -I/home/rivas/Desktop/abinit-8.2.2p/fallbacks/exports/include -g -O2 -mtune=native -march=native -std=c++14 -MT ...
by jbeuken
Sat Feb 18, 2017 3:31 pm
Forum: Configuration
Topic: libblas.so.3 [SOLVED]
Replies: 3
Views: 1853

Re: libblas.so.3 [SOLVED]

need infos ! please...

can you post the output of these cmds :

Code: Select all

uname -ar
dpkg -l| grep blas
echo $LD_LIBRARY_PATH

How did you choose the algebraic library ?
did you use :

Code: Select all

--with-linalg-flavor="netlib"
--with-linalg-libs="-L/PATH/OF/NETLIB/LIBRARY  -llapack -lblas"
 
by jbeuken
Mon Feb 13, 2017 8:24 pm
Forum: Configuration
Topic: how to verify the abinit version [SOLVED]
Replies: 3
Views: 1303

Re: how to verify the abinit version [SOLVED]

Hi, not enough infos ! I have compiled parallel version of abinit on a pentium, dowloading 8.0.8b package. what is the argument of your configure cmd ? are you made a install after compilation ( make install ) ? if yes, what is the value of the argument "--prefix" , When I type : abinit --...
by jbeuken
Mon Feb 13, 2017 8:51 am
Forum: Configuration
Topic: Installation error (no Fortran compiler available) [SOLVED]
Replies: 2
Views: 1721

Re: Installation error (no Fortran compiler available) [SOLVED]

Hi,

...
checking whether we are using the GNU Fortran compiler... no
checking whether accepts -g... no
configure: error: no Fortran compiler available

It is pretty clear...

Code: Select all

dnf install gcc gcc-gfortran 
by jbeuken
Sun Feb 05, 2017 8:42 pm
Forum: Configuration
Topic: problem after make
Replies: 2
Views: 1072

Re: problem after make

Hi,

the configure exits with rc=0 (your config.log ) , then it's ok !
but what are your ubuntu.ac file and the compilation's errors ?

jmb
by jbeuken
Wed Jan 18, 2017 6:37 pm
Forum: Testing and Documentation
Topic: How to run a specific test of the test farm
Replies: 2
Views: 1044

Re: How to run a specific test of the test farm

Hello Jordan, you can find, for example, for the test tutorespfn, the list of of subtests in : cat tests/tutorespfn/__init__ <snip> subsuites = [ "elast", "emp", "eph", "ffield", "nlo", "optic", "rf1", "rf2", ] </snip> t...
by jbeuken
Wed Dec 21, 2016 6:43 pm
Forum: Configuration
Topic: How to configure CUDA MKL GCC in Linux Properly?
Replies: 2
Views: 1641

Re: How to configure CUDA MKL GCC in Linux Properly?

( update of post http://forum.abinit.org/viewtopic.php?f=2&t=2677&p=8233&hilit=cuda#p8233 ) Hello, we have a testfarm and one of the bot tests the cuda functionality ( this bot has 2 x K40 and 2 x Tesla C1060 ) we use gcc47 + mkl + magma ( > 1.6.x ) + cuda 6.5 and compile abinit with ( a...
by jbeuken
Fri Nov 11, 2016 8:33 pm
Forum: Pseudopotentials and PAW datasets
Topic: JTH PAW Atomic Data file for N [SOLVED]
Replies: 2
Views: 1470

Re: JTH PAW Atomic Data file for N [SOLVED]

done...

sorry,

jmb
by jbeuken
Tue Oct 25, 2016 10:46 pm
Forum: Configuration
Topic: Abinit download packages not found [SOLVED]
Replies: 1
Views: 1364

Re: Abinit download packages not found [SOLVED]

sorry...

service enabled now...

jmb
by jbeuken
Tue Oct 04, 2016 9:35 am
Forum: Platform specific questions
Topic: Issue Regarding Parallel Installation of Abinit 8.0.7
Replies: 6
Views: 6461

Re: Issue Regarding Parallel Installation of Abinit 8.0.7

Hi Marco, I also tried to modify the line `` with-trio-flavor ="netcdf+etsf_io" `` in the .ac file and noticed that in the end the configuration does not care if you set netcdf, or netcdf+whatever, since TRIO flavor is set to None. You have to type it by hand after configure to get it corr...
by jbeuken
Mon Aug 08, 2016 7:50 pm
Forum: Configuration
Topic: problem for install abinit 8.0.8 [SOLVED]
Replies: 11
Views: 7872

Re: problem for install abinit 8.0.8 [SOLVED]

please read carefully my post... I didn't speak about "with_netcdf_incs="-I/usr/include" but about : 1) replace everywhere "/usr/lib64" by "/usr/lib" in your ac file 2) add -lfftw3f then replace with_fft_libs="-L/usr/lib64 -lfftw3" by with_fft_libs="...
by jbeuken
Sat Aug 06, 2016 9:16 am
Forum: Configuration
Topic: problem for install abinit 8.0.8 [SOLVED]
Replies: 11
Views: 7872

Re: problem for install abinit 8.0.8 [SOLVED]

Hi forgot to attach "dpkg -l" ? your ac file : prefix="/usr/local" enable_mpi="yes" enable_mpi_io="yes" with_mpi_prefix="/usr" with_netcdf_incs="-I/usr/include" with_netcdf_libs="-L/usr/lib64 -lnetcdf -lnetcdff" with_fft_flavor=&q...
by jbeuken
Fri Aug 05, 2016 12:29 am
Forum: Configuration
Topic: problem for install abinit 8.0.8 [SOLVED]
Replies: 11
Views: 7872

Re: problem for install abinit 8.0.8 [SOLVED]

Hi,

can you provide some more infos :

- version of os : 16.04 or 16.10
- dpkg --list
- cat ubuntu.ac

jmb
by jbeuken
Mon Jul 11, 2016 9:32 pm
Forum: Configuration
Topic: error in compilation of abinit 7.8.2 [SOLVED]
Replies: 2
Views: 1911

Re: error in compilation of abinit 7.8.2 [SOLVED]

Hi, there are some problems with the mpich2 installation : configure:10613: /home/satvindersingh/libs/mpich2/mpich2-install/bin/mpicc --version >&5 gcc (GCC) 4.8.5 configure:13420: /home/satvindersingh/libs/mpich2/mpich2-install/bin/mpif90 --version >&5 GNU Fortran (GCC) 4.1.2 20080704 (Red ...
by jbeuken
Mon Jun 13, 2016 7:34 pm
Forum: Configuration
Topic: Dear every one,does abinit 8 only compatible with >=gcc 5? [SOLVED]
Replies: 2
Views: 3325

Re: Dear every one,does abinit 8 only compatible with >=gcc  [SOLVED]

Hi,

8.0.x is tested on our test farm with : gcc 4.6.4 , 4.7.4, 4.8.2, 4.9.3, 5.3 et 6.1

REM :
I compile the compilers myself...
I have some times problems with compiler package like 5.3.1 from ubuntu 15.10 ( not yet tested with 16.04 )

jmb
by jbeuken
Thu Oct 15, 2015 8:01 pm
Forum: Platform specific questions
Topic: installation problems on mac [SOLVED]
Replies: 12
Views: 9862

Re: installation problems on mac [SOLVED]

Argh !

you are right ! it is in version 7.10.5 ( not published ) :(
find a version of README.MacOSX attached...

I again installed de fortran g77 compiler.


:shock: I don't understand :roll:
we use, at minimum, Fortran 95 and part of Fortran 2003
Fortran 77 can no longer compile ABINIT… ;)

Sorry,

jmb
by jbeuken
Wed Oct 14, 2015 10:07 pm
Forum: Platform specific questions
Topic: installation problems on mac [SOLVED]
Replies: 12
Views: 9862

Re: installation problems on mac [SOLVED]

Hi,

did you read the content of the README.MacOSX file found in the root of source tree of 7.10.4 version ?

jmb
by jbeuken
Thu Oct 08, 2015 10:08 pm
Forum: Platform specific questions
Topic: How can I get abinit binaries for windows 32bits? [SOLVED]
Replies: 2
Views: 4534

Re: How can I get abinit binaries for windows 32bits? [SOLVED]

Hello, the link https://transvol.sgsi.ucl.ac.be/download.php?id=298735237b4bbf8f is expired You can use these permanent links : for 32bit intel : http://ftp.abinit.org/binaries/abinit-6.4.3_prescottSSE3.zip for 32bit AMD : http://ftp.abinit.org/binaries/abinit-6.4.3_amdk8.zip regards
by jbeuken
Tue Sep 15, 2015 8:41 pm
Forum: Configuration
Topic: make problems
Replies: 1
Views: 1336

Re: make problems

the problem is related to the libxc library... are you sure that the libxc is well compiled ? I see that you specified the location of a libxc library : --with-libxc-incs=-I/export1/home/maofei/opt/lixc-2.02/include --with-libxc-libs=-L/export1/home/maofei/opt/lixc-2.02/lib -lxc is it compiled with ...
by jbeuken
Sun Sep 13, 2015 11:27 am
Forum: Ground state
Topic: 24 core running, 48core not for Version 7.10.4 of ABINIT
Replies: 9
Views: 3067

Re: 24 core running, 48core not for Version 7.10.4 of ABINIT

Hi, first of all, the right command for mpi configuration is : ./configure --enable-mpi --with-mpi-prefix=/opt/apps/intel11_1/mvapich2/1.6/ --prefix=/home1/03646/onionbit/software/764abinit/abinit-7.6.4/build --enable-64bit-flags but , you can start with a serial version : ./configure --disable-mpi ...