Search found 346 matches

by jbeuken
Wed Dec 28, 2011 8:49 pm
Forum: Configuration
Topic: [SOLVED] Abint 6.10.3 fails tests on Ubuntu 11.10 server
Replies: 3
Views: 1594

Re: Abint 6.10.3 fails tests on Ubuntu 10.10 server

Hi Sergei, I'm not a specialist of ubuntu but the 6.10.3 is working with recipe for ubuntu 10.04 can you tell me which version of openmpi was installed under 10.10 ? under 10.04 , it's 1.4.1 : we don't support yet 1.5 same for mpich : don't use mpich > 1.3.x : there is a bug in version 1.4.x correct...
by jbeuken
Wed Dec 07, 2011 10:10 pm
Forum: Configuration
Topic: make abinit-6.10.1 fails
Replies: 9
Views: 3247

Re: make abinit-6.10.1 fails

Hi, Thnx but my version is 1.0.7 according to this : # /opt/mpich2/gnu/bin/mpif90 -v mpif90 for 1.0.7 gcc versión 4.1.2 20071124 (Red Hat 4.1.2-42) sorry but it's a very too version of mpich2 the oldest version tested in our test farm is 1.2.1 it is difficult thing for me to solve the problem with s...
by jbeuken
Wed Dec 07, 2011 4:57 pm
Forum: Configuration
Topic: make abinit-6.10.1 fails
Replies: 9
Views: 3247

Re: make abinit-6.10.1 fails

Hi, what is the version of MPICH2 ? there is a bug in the version 1.4.1p1 , see detail in topic : http://forum.abinit.org/viewtopic.php?f=3&t=1206 you must use 1.3.x or the svn version regards jmb How do I find out the version of mpich? mpif90 -v mpif90 for MPICH2 version 1.3 jmb
by jbeuken
Tue Dec 06, 2011 3:36 pm
Forum: Configuration
Topic: make abinit-6.10.1 fails
Replies: 9
Views: 3247

Re: make abinit-6.10.1 fails

Hi,

what is the version of MPICH2 ?

there is a bug in the version 1.4.1p1 , see detail in topic : http://forum.abinit.org/viewtopic.php?f=3&t=1206

you must use 1.3.x or the svn version

regards

jmb
by jbeuken
Tue Dec 06, 2011 2:54 pm
Forum: Configuration
Topic: Problem with compiling abinit 6.10.2 on iMac 2011
Replies: 7
Views: 2165

Re: Problem with compiling abinit 6.10.2 on iMac 2011

Dear xiangpisai,

which is the version of your OS ?
the error can be explained if the version is 10.6.7 or less...

jmb
by jbeuken
Mon Dec 05, 2011 3:37 pm
Forum: Platform specific questions
Topic: Packaging abinit for Fedora/RHEL/CentOS
Replies: 6
Views: 5061

Re: Packaging abinit for Fedora/RHEL/CentOS

HI, I would like to share my experience with the MPI packages with ABinit 6.10.x under Fedora Core 16 ( x86_64 ) I tried with theses two packages without success openmpi-1.5-4.fc16.x86_64 openmpi-devel-1.5-4.fc16.x86_64 mpich2-1.4.1p1-1.fc16.x86_64 mpich2-devel-1.4.1p1-1.fc16.x86_64 1) OpenMPI => ru...
by jbeuken
Mon Dec 05, 2011 10:29 am
Forum: Configuration
Topic: Problem with compiling abinit 6.10.2 on iMac 2011
Replies: 7
Views: 2165

Re: Problem with compiling abinit 6.10.2 on iMac 2011

Hi, I suppose that your iMac2011 runs under Lion (10.7.x)... I download and install the binaries found on : http://gcc.gnu.org/wiki/GFortranBinaries#MacOS ( gcc v4.6.2 ) I add/ajust in my environment : export PATH=/usr/local/gfortran/bin:$PATH export DYLD_LIBRARY_PATH=/usr/local/gfortran/lib:$DYLD_L...
by jbeuken
Sun Dec 04, 2011 10:47 pm
Forum: Configuration
Topic: configure error of 6.10 with gfortran+openmpi on fedora
Replies: 6
Views: 2952

Re: configure error of 6.10 with gfortran+openmpi on fedroa

Hi, in the config.log, you see that the "libmpi.so.1" library is not found : ... configure:11026: $? = 0 configure:11033: ./conftest ./conftest: error while loading shared libraries: libmpi.so.1: cannot open shared object file: No such file or directory configure:11037: $? = 127 ... initia...
by jbeuken
Wed Nov 23, 2011 6:30 pm
Forum: Configuration
Topic: abinit 6.8.1 in paralle by lammpi
Replies: 5
Views: 1740

Re: abinit 6.8.1 in paralle by lammpi

Hi,

mpirun -n 24 -hostfile hostlist abinit<>&log &


perhaps, you forgot input files :(

mpirun -n 24 -hostfile hostlist abinit < files >& log &

jmb
by jbeuken
Sun Nov 13, 2011 8:52 pm
Forum: Platform specific questions
Topic: Problem to installing Abinit-10.6.1 on Opensuse 11.4
Replies: 5
Views: 2983

Re: Problem to installing Abinit-10.6.1 on Opensuse 11.4

problem of privileges...

you can try :

Code: Select all

sudo make install


jmb
by jbeuken
Sun Nov 13, 2011 6:44 pm
Forum: Platform specific questions
Topic: Problem to installing Abinit-10.6.1 on Opensuse 11.4
Replies: 5
Views: 2983

Re: Problem to installing Abinit-10.6.1 on Opensuse 11.4

Hi,

where is the problem ?

Configuration complete successfully...
make also...
mab wrote:zemzemi@linux-6akw:~/DossierCalcul/Dossier_Abinit/abinit-6.10.1>


now, you can :

Code: Select all

make install


or

Code: Select all

cd tests ; make tests_min 


as indicated at the end of make

regards

jmb
by jbeuken
Wed Nov 09, 2011 9:22 pm
Forum: Platform specific questions
Topic: ABINIT for Windows 7, 64 bit
Replies: 9
Views: 5704

Re: ABINIT for Windows 7, 64 bit

Hi Steve,

if you want , you can try the "atompaw.exe" version 3.0.1 ( natif 64 bits windows binary )

link = http://ftp.abinit.org/atompaw.zip

good luck ;)

jmb
by jbeuken
Sat Nov 05, 2011 10:24 pm
Forum: Configuration
Topic: [Q][SOLVED] open64 for abinit?
Replies: 8
Views: 2563

Re: [Q] open64 for abinit?

Hi ByoungSeon, for information, I successed to compile sequential ABINIT 6.9.1 (patched by me (not published)) with the AMD version of open64 ( 4.2.5.1 ) ( m ) under a HP/DL185 ( 2x OctoOpteron ) the result of tests are pretty good... 6.9.1-private/r694 ==============================================...
by jbeuken
Tue Nov 01, 2011 11:02 am
Forum: Platform specific questions
Topic: abinit for windows 7
Replies: 15
Views: 8596

Re: abinit for windows 7

Hi, I should use exactly dots in " ..\..\bin\mpiexec -localonly 2 ..\..\bin\abinit < "t_kpt+spin.files" or replace with directory? you can replace with directory ( full path ) - start as administrator , a "command prompt" to start smpd bin\smpd -install only this command is ...
by jbeuken
Sun Oct 30, 2011 7:46 pm
Forum: Platform specific questions
Topic: ABINIT for Windows 7, 64 bit
Replies: 9
Views: 5704

Re: ABINIT for Windows 7, 64 bit

Hi Steve,

do you already try the version found on "http://ftp.abinit.org/abinit-6.6.2_i686_cygwin_gnu4.5.zip"

( it is a 64bit binary suitable for Windows 7 )

you can see the topics "http://forum.abinit.org/viewtopic.php?f=2&t=1022" for more infos

regards

jmb
by jbeuken
Sat Oct 29, 2011 10:11 pm
Forum: Platform specific questions
Topic: abinit for windows 7
Replies: 15
Views: 8596

Re: abinit for windows 7

Bahaar another precision concerning mpich2 smpd daemon... 1. stopping MPICH2 process Manager, Argonne National lab. 2. MPICH2 process Manager, Argonna National lab Stopped. 3. MPICH2 process Manager, Argonna National lab removed. if the "bin\snmp -install" had been already started, the ser...
by jbeuken
Sat Oct 29, 2011 9:51 pm
Forum: Platform specific questions
Topic: abinit for windows 7
Replies: 15
Views: 8596

Re: abinit for windows 7

Hello, First of all, I'm just trying the recipe with my PC with a fresh windows 7 installation and the "abinit-6.6.3_i686_cygwin_gnu4.5.zip" package For parallel i have a question. I use the "bin\smpd -install" command as determined in readme. except for the command "bin\smp...
by jbeuken
Sat Oct 29, 2011 8:25 pm
Forum: Configuration
Topic: Abinit 6.8.1 + OpenMPI = FAIL [SOLVED]
Replies: 13
Views: 9911

Re: Abinit 6.8.1 + OpenMPI = FAIL [SOLVED]

Hello, this is my recipe for a Core-i7 / ubuntu 10.04 (64bits) / abinit 6.8.2 or 6.10.1 ( tested under our testfarm ) : from a fresh install : 1) installation of theses packages : apt-get -y install gcc gfortran apt-get -y install patch apt-get -y install libnetcdf4 libnetcdf-dev apt-get -y install ...
by jbeuken
Sat Oct 29, 2011 8:07 pm
Forum: Configuration
Topic: ifort + abinit 6.8.2 = fail
Replies: 3
Views: 1908

Re: ifort + abinit 6.8.2 = fail

Hello,

roginovicci wrote:No the mpich is 1.2 should I ask to upgrade up to 1.4?


can you try first with the version 1.3.2p1 ?

if you want to use the version 1.4.1p1 , see before the thread :http://forum.abinit.org/viewtopic.php?f=3&t=1206

jmb
by jbeuken
Sun Oct 23, 2011 7:30 pm
Forum: Platform specific questions
Topic: remote access to supercomputer or cluster [SOLVED]
Replies: 5
Views: 4337

Re: remote access to supercomputer or cluster [SOLVED]

Hi,

My question is: is it possible (preferably free or inexpensive) to obtain remote access to supercomputer? If so, where and how?


take a look on : http://www.abinit.org/news/abinit-on-nanohub

jmb
by jbeuken
Wed Oct 12, 2011 8:11 pm
Forum: Platform specific questions
Topic: log file
Replies: 4
Views: 1732

Re: log file

Hi,

I use the v.6.6.3 of abinit installed on windows and use the abinit<ab.files command to run the code. when i use abinit<ab.files&log command, cod runs as well but no log file appears in the output.


and with

Code: Select all

abinit < ab.files >& log


jmb
by jbeuken
Mon Oct 10, 2011 3:59 pm
Forum: Configuration
Topic: ifort + abinit 6.8.2 = fail
Replies: 3
Views: 1908

Re: ifort + abinit 6.8.2 = fail

Hello, the version of mpich2 is 1.4.x ? if yes, perhaps your problem is related of a problem with mpich2 not with abinit then you can read this topic ( http://trac.mcs.anl.gov/projects/mpich2/changeset/8834 ) reproduced here : Index: /mpich2/branches/release/mpich2-1.4.x/RELEASE_NOTES ==============...
by jbeuken
Mon Oct 10, 2011 3:44 pm
Forum: Configuration
Topic: abinit 6.8.1 + gfortran + mpich2 = no compile
Replies: 7
Views: 4947

Re: abinit 6.8.1 + gfortran + mpich2 = no compile

Hi Steven, sorry for this long delay of in my reaction... --- src/binding/f90/buildiface 2011-03-20 15:37:51.000000000 -0400 +++ ../../mpich2-1.4/src/binding/f90/buildiface 2011-07-25 19:12:52.529963846 -0400 @@ -189,6 +189,7 @@ 'Op_commutative-2' => 'bool', 'File_set_atomicity-2' => 'bool', 'File_g...
by jbeuken
Sat Oct 08, 2011 3:28 pm
Forum: Configuration
Topic: Abinit 6.8.2 compile error with openmpi & pathscale
Replies: 2
Views: 1530

Re: Abinit 6.8.2 compile error with openmpi & pathscale

Hello, /tmp/pathcc-s-74b0dc51.s:4669:2: error: ORG overlap with already existing data .org 0x0 ^ I had this error with the "free" version ( nightly build = develpoment ) ( I had introduce a bug report...) I was able to compile the version 6.8 ( and 6.10 ) but with the paid version pathf90 ...
by jbeuken
Thu Aug 18, 2011 2:34 pm
Forum: Platform specific questions
Topic: checking if Fortran "real" is C "float"... configure: error
Replies: 10
Views: 4337

Re: checking if Fortran "real" is C "float"... configure: er

Hello Anna, I suspect a problem of architecture (32bit vs 64bit) can you use this configure command with the 64bit enabled ( and a additionnal lib with netcdf option ( netcdff = netcdf for fortran ) ) : ../abinit-6.6.1_invKS/configure \ --with-fallbacks-tardir=/Users/anna/Documents/anna/1projects/si...