Search found 343 matches

by jbeuken
Fri Jul 27, 2012 3:16 pm
Forum: Configuration
Topic: [SOLVED] Problem when compiling 6.12.3 with Openmpi
Replies: 18
Views: 7027

Re: [SOLVED] Problem when compiling 6.12.3 with Openmpi

Hi, I met a similar problem when configuring and making abinit 6.12.3 that atompaw play a key role. If I took atompaw in the "with-dft-favor", it will occur an unexpected error when installation, however ,if I don't write "atompaw" in "with-dft-favor" manually, the inst...
by jbeuken
Fri Jul 27, 2012 10:59 am
Forum: Configuration
Topic: Compiling error for 77_ddb/nmsq_pure_gkk_sumfs.F90 in SUSE
Replies: 2
Views: 1703

Re: Compiling error for 77_ddb/nmsq_pure_gkk_sumfs.F90 in SU

Hi, we have a bot with CentOS 6.3 / Xeon W3520 and ifort 12.1.4 with openmpi 1.6.0 we compile with the same options ( -O2 -xHost -g -extend-source -vec-report0 -noaltparam -nofpscomp ) and it works : [buildbot@coba2 77_ddb]$ ifort -V Intel(R) Fortran Intel(R) 64 Compiler XE for applications running ...
by jbeuken
Sun Jul 01, 2012 9:13 pm
Forum: Link to other codes
Topic: [SOLVED] Error on running tutorial tw90_4 with_abinit6.12.3
Replies: 2
Views: 5160

Re: Error on running tutorial tw90_4 with_abinit6.12.3

Hi Thanusit,

for info, the use of version intel 12.1.4 under CentOS 6.2 works with abinit....

regards

jmb
by jbeuken
Sun Jul 01, 2012 9:03 pm
Forum: Platform specific questions
Topic: Abinit 6.12.3 on Win7 64bit [SOLVED]
Replies: 2
Views: 3456

[CORRECTED/UPDATED] Re: Abinit 6.12.3 on Win7 64bit [SOLVED]

Hi,

abinit run natively under the "command prompt" of Windows and ALSO under cygwin...

the DLL were missing in the package : a new package is available !

sorry,

jmb
by jbeuken
Tue Jun 19, 2012 9:02 pm
Forum: Configuration
Topic: error in compilation abinit-6.12.3
Replies: 1
Views: 1217

Re: error in compilation abinit-6.12.3

Hi, Error: checking for patch.........no configure: error: BigDFT requires patch-disable BigDFT or install patch the answers are suggested : "disable BigDFT or install patch" to disable BigDFT, add to configure --with-dft-flavor="atompaw+libxc+wannier90" or install "patch&qu...
by jbeuken
Sun Jun 17, 2012 8:07 pm
Forum: Configuration
Topic: [SOLVED] Problem when compiling 6.12.3 with Openmpi
Replies: 18
Views: 7027

Re: [SOLVED] Problem when compiling 6.12.3 with Openmpi

Hi, I didn't remember precisely why but it's better to use the intel version 11.1.073 ( in any case to use mpiio ) concerning the problem to use mkl and/or the compile atompaw, this is my recipe working on our test farm : before to run configure, set your env by ( I use the paths of your env, you re...
by jbeuken
Tue Jun 12, 2012 8:11 pm
Forum: Configuration
Topic: [SOLVED] Problem when compiling 6.12.3 with Openmpi
Replies: 18
Views: 7027

Re: Problem when compiling 6.12.3 with Openmpi

Hi, 5.Unfortunately, even it compiles ans installs successfully (abinit generated in /bin folder), abinit still cannot run, use command mpirun -np 12 /usrname/software/abinit-6.12.3/bin/abinit <filename.files>& log the log file shows Fatal error in MPI_Init: Other MPI error what are the results ...
by jbeuken
Tue Jun 12, 2012 8:03 pm
Forum: Configuration
Topic: Fortran could not compile .f90 files during 'make' [SOLVED]
Replies: 20
Views: 12528

Re: Fortran could not compile .f90 files during 'make' [SOLVED]

Hi Igor,

the very old gcc 4.1.2 is anymore supported for abinit...

at least, upgrade to 4.4.x

jmb
by jbeuken
Tue May 22, 2012 7:52 pm
Forum: Testing and Documentation
Topic: [FIXED] v6.12 openings tutorial page needs fixing.
Replies: 1
Views: 2423

Re: v6.12 openings tutorial page needs fixing.

Hi...

fixed...

sorry for the delay...

jmb
by jbeuken
Tue May 22, 2012 7:48 pm
Forum: Configuration
Topic: abinit-6.12.3 - getting a clean make check
Replies: 2
Views: 1748

Re: abinit-6.12.3 - getting a clean make check

Dear Thomas, first of all, use intel compilers 11.1.073 or >= 12.1. 4 when I use intel compilers, I use fftw3 implemented under mkl like : with_fft_flavor="fftw3" with_fft_libs="-L/opt/intel/Compiler/11.1/current/mkl/lib/em64t -Wl,--start-group -lmkl_intel_lp64 -lmkl_sequential -lmkl_...
by jbeuken
Fri Apr 27, 2012 9:59 pm
Forum: Bazaar repositories and branches
Topic: 6.15 bigdft fallback linking
Replies: 1
Views: 5832

Re: 6.15 bigdft fallback linking

Hi Matth, there are a lot of problems with BigDFT 1.6.0.6 : with intel 11.1, xlf12 and gcc45/mingw/Windows (on testfarm, bigdft tests are temporarily disabled on slaves coba2, woopy and ibm6 ) the problem of loc[rR]eg is already signaled to Damien some other problems may be solved in BigDFT 1.6.0.7....
by jbeuken
Tue Apr 17, 2012 8:09 pm
Forum: Platform specific questions
Topic: Abinit 7.4.3 binaries for Windows 64bits posted
Replies: 0
Views: 5246

Abinit 7.4.3 binaries for Windows 64bits posted

Dear All, A new binary package for Abinit 7.4.3 for Windows 64bits has been posted on the ABINIT website and can be downloaded from here . Abinit 7.4.3 is the latest production release as of 20/10/2013 . This 64bit Windows version comes with all advertised plugins and required libraries. It passes t...
by jbeuken
Sat Apr 14, 2012 9:09 pm
Forum: Configuration
Topic: 【Solved】Compiling error in 12_hide_mpi by PathScale
Replies: 4
Views: 2401

Re: Compiling error in 12_hide_mpi by PathScale

Dear Gao Zhe, In our test farm, we have a bot with PathScale Compiler ( ekopath 4.0.12 ) and use OpenMPI 1.4.4. with version 6.12.3, all tests ( with all plugins ) pass except test Q4 of MPI-IO my some tests with the nightly version have failed ( even with the paid version < 4.0.12 ) for infos : thi...
by jbeuken
Wed Apr 11, 2012 7:45 pm
Forum: Platform specific questions
Topic: Installing abinit parallel on centOS 5.6
Replies: 3
Views: 3176

Re: Installing abinit parallel on centOS 5.6

Hello

* C compiler : gnu version 4.1
* Fortran compiler: gnu version 4.1


this version is very very very old and never supported :roll:

the last supported version is gcc 4.3.x

with this old OS version, it's possible to install gcc 4.4

Code: Select all

yum install gcc44-gfortran.x86_64


good luck

jmb
by jbeuken
Tue Apr 10, 2012 9:28 pm
Forum: Platform specific questions
Topic: Installing abinit parallel on centOS 5.6
Replies: 3
Views: 3176

Re: Installing abinit parallel on centOS 5.6

Hi,

not enough infos !

- your configure command and the config.log
- result of command

Code: Select all

which gfortran


jmb
by jbeuken
Tue Apr 10, 2012 9:22 pm
Forum: Platform specific questions
Topic: Compiling 6.13.3 in Lion Mac OS [SOLVED]
Replies: 20
Views: 24544

Re: Compiling 6.13.3 in Lion Mac OS [SOLVED]

Hi, ... it yields a MKDIR_P variable of something... concerning the problem of MKDIR_P, you can try these "solutions" : 1) export MKDIR_P="/bin/mkdir -p" 2) install "coreutils" package with MacPort or fink and change the PATH variable the "/bin/mkdir" of MacOS...
by jbeuken
Mon Apr 09, 2012 11:44 pm
Forum: Platform specific questions
Topic: Issues compiling abinit 6.12.1 on Power6
Replies: 6
Views: 2690

Re: Issues compiling abinit 6.12.1 on Power6

use -P with version 12

jmb
by jbeuken
Mon Apr 09, 2012 9:54 am
Forum: Platform specific questions
Topic: make magma
Replies: 4
Views: 3046

Re: make magma

Hi,

If the environment is 64bits, try without "-L$(CUDADIR)/lib"


Code: Select all

...
LIBDIR = -L/usr/lib/atlas-base \
-L/usr/lib \
-L/lib \
-L/usr/lib/lapack \
-L$(CUDADIR)/lib64

INC = -I$(CUDADIR)/include
...


jmb
by jbeuken
Sun Apr 08, 2012 8:35 pm
Forum: Platform specific questions
Topic: Issues compiling abinit 6.12.1 on Power6
Replies: 6
Views: 2690

Re: Issues compiling abinit 6.12.1 on Power6

Hi,

a little question :

in the /etc/xlf.cfg.[53|61|71]

have you the -P for cppotions ?

Code: Select all

* Common definitions
DEFLT:    xlf     = /usr/lpp/xlf/bin/xlfentry
...
          cppoptions = -P
...


jmb
by jbeuken
Sun Apr 08, 2012 8:24 pm
Forum: Platform specific questions
Topic: make magma
Replies: 4
Views: 3046

Re: make magma

Hi magniff, LIBDIR = -L/usr/lib/atlas-base \ -L/usr/lib \ -L/lib \ -L/home/magniff/Desktop/downloads/magma_1.1.0/lib \ -L/usr/lib/lapack \ -L$(CUDADIR)/lib64 \ -L$(CUDADIR)/lib INC = -I$(CUDADIR)/include \ LIBMAGMA = /home/magniff/Desktop/downloads/magma_1.1.0/lib/magma.a LIBMAGMABLAS = /home/magnif...
by jbeuken
Sat Mar 31, 2012 9:14 pm
Forum: Platform specific questions
Topic: Issues compiling abinit 6.12.1 on Power6
Replies: 6
Views: 2690

Re: Issues compiling abinit 6.12.1 on Power6

Hi, the configuration of our bot ( Power6 / AIX 6.1 / xlf 12.1 ) seems very similar the section mpxlf90_r in our /etc/xlf.cfg.61 file ( or /etc/xlf.cfg.53 ) is exactly the same as your... and we have no problem ( you can see the make output here for the abinit version 6.12.3 : m ) perhaps , the vers...
by jbeuken
Tue Mar 27, 2012 9:00 pm
Forum: Platform specific questions
Topic: Intel mkl library
Replies: 5
Views: 4813

Re: Intel mkl library

Hi, I have not yet the opportunity to test the version of mph with Intel Composer XE 2011... but, in the "Intel® Math Kernel Library Link Line Advisor" ( m), you can find all infos needed and among other things, the compilation option to use with fort to activate the mph -mkl=cluster you m...
by jbeuken
Tue Mar 27, 2012 7:51 pm
Forum: Configuration
Topic: abinit-6.12.1. Compiler error at ATOMPAW
Replies: 10
Views: 9537

Re: abinit-6.12.1. Compiler error at ATOMPAW

Hi Temok, Such config.log is attached in this reply. Please note that such log file corresponds for the case ifort 12.1 + openmpi-1.4.5, which I have desisted under your suggestion with this config.log, it's simple to find the problem... ... ./conftest: error while loading shared libraries: libmkl_i...
by jbeuken
Mon Mar 26, 2012 9:17 pm
Forum: Configuration
Topic: abinit-6.12.1. Compiler error at ATOMPAW
Replies: 10
Views: 9537

Re: abinit-6.12.1. Compiler error at ATOMPAW

Hi Temok, 2 things : 1) forget the ifort 12.1 : after analysis of tests results, there are too big errors then it seems that the compiler is not yet ready to use with Abinit use the version 11.1.073 : it works with 6.12.2 , all plugins and openmpi 1.4.3 2) you have a problem with wannier90, then we ...