Search found 339 matches

by jbeuken
Thu Sep 10, 2015 8:43 pm
Forum: Ground state
Topic: 24 core running, 48core not for Version 7.10.4 of ABINIT
Replies: 9
Views: 3067

Re: 24 core running, 48core not for Version 7.10.4 of ABINIT

I think that the last version abinit compatible with intel 11 is 7.6

http://www.abinit.org/downloads/packages/7-6.4

regards

jmb
by jbeuken
Wed Sep 09, 2015 7:56 pm
Forum: Configuration
Topic: make errors [SOLVED]
Replies: 8
Views: 3641

Re: make errors [SOLVED]

officially, gcc >= 4.6
but abinit 7.10.x works with gcc 4.8 or 4.9

jmb
by jbeuken
Tue Sep 08, 2015 7:38 pm
Forum: Ground state
Topic: 24 core running, 48core not for Version 7.10.4 of ABINIT
Replies: 9
Views: 3067

Re: 24 core running, 48core not for Version 7.10.4 of ABINIT

Hi,

You can't use ifort 11.x to compile abinit 7.x

for intel compilers, only these versions are supported : >= 12.1.7, >= 13.1.3, >= 14.0.4, == 15.0.3.187

regards

jmb
by jbeuken
Tue Sep 08, 2015 7:36 pm
Forum: Configuration
Topic: make errors [SOLVED]
Replies: 8
Views: 3641

Re: make errors [SOLVED]

Hi,

You can't use ifort 11 to compile abinit 7

for intel compilers, only these versions are supported : >= 12.1.7, >= 13.1.3, >= 14.0.4, == 15.0.3.187

regards

jmb
by jbeuken
Mon Sep 07, 2015 9:03 pm
Forum: Configuration
Topic: make errors [SOLVED]
Replies: 8
Views: 3641

Re: make errors [SOLVED]

Hi, in the config.log, I see some problems in the configure command : $ ./configure --prefix=/export1/home/maofei/opt/abinit_v7.10/sopt2 FC=ifort CC=icc CXX=icpc FCFLAGS=-fPIC --with-tardir=/export1/home/maofei/src/plugins --enable-64bit-flags=yes --with-trio-flavor=netcdf+etsf_io+fox --with-netcdf-...
by jbeuken
Tue Aug 11, 2015 9:37 pm
Forum: Configuration
Topic: Same time to run with more processors [SOLVED]
Replies: 3
Views: 1988

Re: Same time to run with more processors [SOLVED]

Hi, first of all, 7s in 1 CPU is not enough to use this test for scalability evaluation… there are overheads with I/O ( read input file, write results,… ) try to find a test with time around 10 mins… concerning MPICH in SMP ( one computer with some cores ) check the configure : you needs at least : ...
by jbeuken
Tue Jul 21, 2015 8:02 pm
Forum: Configuration
Topic: abinit 7.10.4 compile problem [SOLVED]
Replies: 2
Views: 2361

Re: abinit 7.10.4 compile problem [SOLVED]

Hi,
the compiler version is no longer supported…

use :
    version 13.1.3 or better
    version 14.0.4 or better
by jbeuken
Sat Jul 11, 2015 8:19 pm
Forum: Platform specific questions
Topic: gcc on a Macbook: living with an AVX-enabled processor [SOLVED]
Replies: 9
Views: 8813

Re: gcc on a Macbook: living with an AVX-enabled processor [SOLVED]

Hello Gabi, with MacPorts under Yosemite and with AVX-enabled processor, I confirm that with this .ac file, it works…. : CFLAGS="-O2 -g" CXXFLAGS="-O2 -g" FCFLAGS="-O2 -g -ffree-line-length-none" enable_mpi="yes" enable_mpi_io="yes" with_mpi_prefix=&...
by jbeuken
Mon Jul 06, 2015 10:25 pm
Forum: Configuration
Topic: configure problem [SOLVED]
Replies: 4
Views: 2373

Re: configure problem [SOLVED]

Hi, the configure file is perhaps good… but the problem is : configure: downloading LIBXC - this may take a while configure: downloading LIBXC - this may take a while configure: error: could not download LIBXC fallback tar ball I see "hostname = Node6" in the config.log… if this node is pa...
by jbeuken
Fri Jul 03, 2015 11:10 pm
Forum: Platform specific questions
Topic: gcc on a Macbook: living with an AVX-enabled processor [SOLVED]
Replies: 9
Views: 8813

Re: gcc on a Macbook: living with an AVX-enabled processor [SOLVED]

Hello Gabi, I have new servers for the test farm with new Haswell processors : Xeon(R) CPU E5-2670 v3 @ 2.30GHz I have also a MacPro under Yosemite with cpu with AVX capability sysctl -n machdep.cpu.brand_string Intel(R) Xeon(R) CPU E5-2697 v2 @ 2.70GHz some experiences/ascertainments : 1) a bot und...
by jbeuken
Tue Jun 02, 2015 7:46 pm
Forum: Pseudopotentials and PAW datasets
Topic: error for JTH PAW atomic datasets table [SOLVED]
Replies: 3
Views: 2945

Re: error for JTH PAW atomic datasets table [SOLVED]

corrected…

( side effect after migration of the website )

jmb
by jbeuken
Sun May 03, 2015 9:41 am
Forum: Configuration
Topic: Extremely slow for file ptg_Oh.F90 compiling [SOLVED]
Replies: 1
Views: 1806

Re: Extremely slow for file ptg_Oh.F90 compiling [SOLVED]

Hi,

you can put in front of configure command this option :

Code: Select all

fcflags_opt_43_ptgroups="-g -O0"    ./configure ...


the optimization in the folder "src/43_ptgroups/" is not necessary…

jmb
by jbeuken
Tue Apr 07, 2015 7:38 pm
Forum: Configuration
Topic: parallel error [SOLVED]
Replies: 32
Views: 11318

Re: parallel error [SOLVED]

As I have gfortran, I did this: ... … and this is the summary: Summary of important options: * C compiler : gnu version 4.6 * Fortran compiler: intel version 12.1 * architecture : amd opteron (64 bits) as you can see, you do not use gfortran but ifort version 12.1 !?! and, it's normal that there is...
by jbeuken
Sun Apr 05, 2015 8:43 pm
Forum: Configuration
Topic: parallel error [SOLVED]
Replies: 32
Views: 11318

Re: parallel error [SOLVED]

if you use gfortran ( than GNU GCC but with mkl ) then use --with-linalg-flavor="mkl" \ --with-linalg-incs="-I/opt/intel/composer_xe_2011_sp1.10.319/mkl/include/intel64/lp64" \ --with-linalg_libs="-L/opt/intel/composer_xe_2011_sp1.10.319/mkl/lib/intel64 -Wl,--start-group -lm...
by jbeuken
Fri Apr 03, 2015 10:29 am
Forum: Configuration
Topic: parallel error [SOLVED]
Replies: 32
Views: 11318

Re: parallel error [SOLVED]

Hi if use this command line: ./configure \ --with-linalg-flavor="mkl" \ --with-linalg-incs="-I$opt/intel/composer_xe_2011_sp1.10.319/mkl/include/intel64/lp64" \ --with-linalg_libs="-L$opt/intel/composer_xe_2011_sp1.10.319/mkl/lib/intel64 -Wl,--start-group -lmkl_intel_lp64 -l...
by jbeuken
Wed Mar 25, 2015 11:11 pm
Forum: Configuration
Topic: parallel error [SOLVED]
Replies: 32
Views: 11318

Re: parallel error [SOLVED]

Hi,

you don't had permission to write in the /usr/local/bin :

/usr/bin/install: cannot create regular file `/usr/local/bin/abinit': Permission denied


try with :

Code: Select all

sudo make install
by jbeuken
Fri Feb 20, 2015 7:39 pm
Forum: Configuration
Topic: parallel error [SOLVED]
Replies: 32
Views: 11318

Re: parallel error [SOLVED]

ok…

mpif90:
/usr/local/openmpi/bin/mpif90


then, at least, the configure command must be :

Code: Select all

./configure --enable-mpi --with-mpi-prefix="/usr/local/openmpi"


we progress…
by jbeuken
Tue Feb 17, 2015 7:50 pm
Forum: Configuration
Topic: Abinit keeps using fallback
Replies: 11
Views: 4024

Re: Abinit keeps using fallback

It is blue gene. could you try to inspire you with the solution explained in the post : http://forum.abinit.org/viewtopic.php?f=2&t=1690&p=5264&hilit=Blue+Gene#p5264 with_linalg_libs="-L/usr/local/tools/scalapack/lib -lscalapack" with_linalg_libs="-L/usr/local/tools/lapac...
by jbeuken
Tue Feb 17, 2015 8:58 am
Forum: Configuration
Topic: parallel error [SOLVED]
Replies: 32
Views: 11318

Re: parallel error [SOLVED]

I just used the commands that mention on the link I posted. commands line do not depend on the version, right?


yes and no !

some configure options have been removed while others have been added …

concerning the MPI support, what are the results of theses commands :

Code: Select all

env
which mpif90
by jbeuken
Mon Feb 16, 2015 10:09 pm
Forum: Configuration
Topic: parallel error [SOLVED]
Replies: 32
Views: 11318

Re: parallel error [SOLVED]

outdated !
please use a more recent version of abinit ( 7.10.2 )
by jbeuken
Mon Feb 16, 2015 10:02 pm
Forum: Configuration
Topic: Abinit keeps using fallback
Replies: 11
Views: 4024

Re: Abinit keeps using fallback

I make a typo ! it's not "which elf" but which xlf is it a Blue Gene machine ? perhaps, you can try with FC=/usr/local/bin/mpif90-latestmpi CC=/usr/local/bin/mpixlc-latestmpi what are the results of commands : /usr/local/bin/mpif90-latestmpi /usr/local/bin/mpixlc-latestmpi -show what is th...
by jbeuken
Mon Feb 16, 2015 8:24 pm
Forum: Configuration
Topic: Fortran could not compile .f90 files during 'make' [SOLVED]
Replies: 20
Views: 12374

Re: Fortran could not compile .f90 files during 'make' [SOLVED]

I also used " --enable-optim=aggressive" and "FPP=/usr/bin/cp" at the configuration stage but nothing.


perhaps a typo in your FPP :roll:

try with :

Code: Select all

FPP=/usr/bin/cpp
by jbeuken
Sun Feb 15, 2015 7:20 pm
Forum: Post-processing Tools
Topic: band structure visualization
Replies: 5
Views: 3153

Re: band structure visualization

Please, use a more recent abinit version ( 7.10.2 )

Concerning the script AbinitBandStructureMaker.py, you need a Python with version > 2.6 , and the module numpy installed…

jmb
by jbeuken
Sun Feb 15, 2015 7:10 pm
Forum: Configuration
Topic: parallel error [SOLVED]
Replies: 32
Views: 11318

Re: parallel error [SOLVED]

need more infos !!!

your configure command ( ./configure and/or the config.log )
your environment ( env, PATH, which mpif90, mpif90 -show,… )

thx