Search found 522 matches

by pouillon
Fri Feb 07, 2020 3:38 pm
Forum: Configuration
Topic: Abinit 8.10.3 compiled with gnu 9.1: DFT calculation crash [SOLVED]
Replies: 8
Views: 767

Re: Abinit 8.10.3 compiled with gnu 9.1: DFT calculation crash [SOLVED]

Dear Davide,

Thank you for reaching out and for the patch. From what I see, this is already fixed in the development branch of ABINIT.

FYI, the --enable-netcdf-default option is only used for testing purposes and will be removed from the upcoming ABINIT 9.0.
by pouillon
Tue Mar 05, 2019 4:56 pm
Forum: Configuration
Topic: Undefined reference error when compiling ABINIT 8.10.2 [SOLVED]
Replies: 5
Views: 1048

Re: Undefined reference error when compiling ABINIT 8.10.2 [SOLVED]

Please note that GSL support is about to be removed because it is highly marginal and unmaintained. The only call to it occurs in src/32_util/m_special_funcs.F90.

You can safely leave it disabled.
by pouillon
Sun Jan 13, 2019 10:35 pm
Forum: Build system
Topic: Can't enable options
Replies: 2
Views: 1188

Re: Can't enable options

In order to know which options the configure script of ABINIT accepts, you just have to run:

./configure --help

from the top ABINIT source directory.
by pouillon
Sun Jan 13, 2019 10:33 pm
Forum: Build system
Topic: confugure fails with Intel ifort 19 compiler
Replies: 4
Views: 1356

Re: configure fails with Intel ifort 19 compiler

I'll fix this ASAP. This will be released in the next version of ABINIT. In the meantime, if you have the Autotools installed on your system, you can edit the following files: * config/hints/cc_intel_default-hints.conf * config/hints/fc_intel_default-hints.conf and run config/scripts/makemake before...
by pouillon
Fri Jun 08, 2018 10:51 am
Forum: Build system
Topic: 8.8.2: m_pawxc.F90 build error
Replies: 2
Views: 2065

Re: 8.8.2: m_pawxc.F90 build error

FYI: The bugfix for this problem is currently in the pipes and will be made available with ABINIT 8.8.3. Thank you for your patience.

A temporary measure could be to rebuild ABINIT with an older version of GCC.
by pouillon
Mon Feb 19, 2018 2:15 pm
Forum: Configuration
Topic: Compiling Abinit with Wannier90 for Z2Pack
Replies: 2
Views: 1260

Re: Compiling Abinit with Wannier90 for Z2Pack

You should use the option:

Code: Select all

with_dft_flavor=libxc+wannier90
by pouillon
Fri Jul 21, 2017 5:53 pm
Forum: Configuration
Topic: How can I compile LIBXC-4.0.0 with abinit-8.0.8
Replies: 3
Views: 2783

Re: How can I compile LIBXC-4.0.0 with abinit-8.0.8

If you have the Autotools (autoconf, automake, libtool) installed on your computer, you can edit config/m4/conn-dft.m4 and change line 216 from: ]])], [abi_dft_libxc_version="yes"], [abi_dft_libxc_version="no"] to: ]])], [abi_dft_libxc_version="yes"], [abi_dft_libxc_ver...
by pouillon
Fri Jul 21, 2017 5:45 pm
Forum: Configuration
Topic: Compilation error with gcc 7.1 [SOLVED]
Replies: 4
Views: 2811

Re: Compilation error with gcc 7.1 [SOLVED]

In progress. You can follow the MR from the Abinit Gitlab: https://gitlab.abinit.org/trunk/abinit/ ... quests/174
by pouillon
Fri Jul 21, 2017 5:24 pm
Forum: Configuration
Topic: Compilation Error using 8 Byte Integers (Intel Compiler)
Replies: 1
Views: 1360

Re: Compilation Error using 8 Byte Integers (Intel Compiler)

I've reported this issue in the bug tracker of the Abinit Gitlab. You can follow its evolution at: https://gitlab.abinit.org/trunk/abinit/issues/19
by pouillon
Fri Jul 21, 2017 5:10 pm
Forum: Jobs and Other Announcements
Topic: Post-doc position in San Sebastián, Spain
Replies: 0
Views: 1021

Post-doc position in San Sebastián, Spain

We are seeking to fill a postdoctoral position opened at Centro de Física de Materiales (m) at the group of Prof. Daniel Sánchez-Portal (m). The work will focus on the optimization and development of the Ehrenfest dynamics (real-time TDDFT) options on SIESTA (in collaboration with the group of Prof....
by pouillon
Thu Mar 09, 2017 4:05 pm
Forum: Link to other codes
Topic: [SOLVED 6.0.4] how to link abinit to Vsim?
Replies: 16
Views: 12519

Re: [SOLVED 6.0.4] how to link abinit to Vsim?

Abinit bindings to V_Sim are currently broken and unmaintained. They might be replaced by something else in the near future. There will be developers meeting this year where we will decide what to do with this part of the code. We will inform you when a decision has been taken.
by pouillon
Thu Nov 24, 2016 5:45 pm
Forum: Configuration
Topic: HOWTO: building Abinit on Linux computers
Replies: 2
Views: 15264

Re: HOWTO: building Abinit on Linux computers

If you have access to a graphical interface based on Unity or Gnome, go to System settings > Software & Updates. You will see a "Download from" field. Choose an appropriate server there.
by pouillon
Thu Nov 24, 2016 12:15 pm
Forum: Platform specific questions
Topic: MPI support broken error while configuring abinit-7.8.2.
Replies: 3
Views: 4967

Re: MPI support broken error while configuring abinit-7.8.2.

You are using a prehistoric 4.1 version of GCC. Please upgrade your compilers to at least version 4.8.
by pouillon
Thu Nov 24, 2016 12:11 pm
Forum: Platform specific questions
Topic: problem with configuring Abinit with libXC on MacOs
Replies: 2
Views: 2746

Re: problem with configuring Abinit with libXC on MacOs

Mac OS is a bit picky about library order. Just reverse "-lxc -lxcf90" to "-lxcf90 -lxc" and it should work.
by pouillon
Thu Nov 24, 2016 12:08 pm
Forum: Configuration
Topic: How can I compile LIBXC-4.0.0 with abinit-8.0.8
Replies: 3
Views: 2783

Re: How can I compile LIBXC-4.0.0 with abinit-8.0.8

Abinit 8.0 is compatible with LibXC 2.2. Unless you need a very recently added functional, you should use this version.

If you do need LibXC 3.0, please wait for the upcoming Abinit 8.2.
by pouillon
Thu Nov 24, 2016 12:05 pm
Forum: Configuration
Topic: Trying to test while configuring. But failed every time.
Replies: 7
Views: 4231

Re: Trying to test while configuring. But failed every time.

Just install NetCDF on your computer and make sure you have the Fortran module. It should be in /usr/include after installation.
by pouillon
Tue Sep 13, 2016 4:30 pm
Forum: Build system
Topic: POWER8 Compatibility: -march=native not available
Replies: 1
Views: 5626

Re: POWER8 Compatibility: -march=native not available

This happens because you are using an old version of GCC which is not supported anymore by the build system. Please upgrade your GCC to version 4.8 or above. We currently recommend GCC 5.4 and are working on fully supporting GCC 6. In the meantime, you can specify optimization flags when running con...
by pouillon
Tue Sep 13, 2016 3:49 pm
Forum: Build system
Topic: POWER8 Compatibility: Update config.guess
Replies: 1
Views: 1351

Re: POWER8 Compatibility: Update config.guess

There has obviously been a mistake when generating the source tarball, with the use of an outdated version of the Autotools. We will take care of generating the future releases of all Abinit components with an up-to-date development environment. In the meantime, since you are not using any optional ...
by pouillon
Tue Aug 23, 2016 1:00 pm
Forum: Platform specific questions
Topic: Issue Regarding Parallel Installation of Abinit 8.0.7
Replies: 6
Views: 6327

Re: Issue Regarding Parallel Installation of Abinit 8.0.7

This is a problem with your MPI installation, not with Abinit. Please consult their documentation / forums / mailing lists and/or re-install MPI.
by pouillon
Mon Apr 18, 2016 10:27 pm
Forum: Link to other codes
Topic: Can not link abinit to ELPA libraries.
Replies: 1
Views: 2444

Re: Can not link abinit to ELPA libraries.

We have identified a few bugs in the detection of linear algebra, that will be fixed in the upcoming 8.0 and 8.2 versions of Abinit. In the meantime, you may try the following: ../configure [your options] \ CPPFLAGS_EXTRA="-DHAVE_LINALG_ELPA -DHAVE_LINALG_ELPA_2015" \ FPPFLAGS_EXTRA="...
by pouillon
Mon Apr 18, 2016 10:19 pm
Forum: Platform specific questions
Topic: Fail Build Abinit v7.10.5 with LibXC
Replies: 2
Views: 3658

Re: Fail Build Abinit v7.10.5 with LibXC

This problem is likely not related to Abinit. Looks like LibXC doesn't like the space character in your install path. Please rename "Abinit instalation" to "Abinit_instalation" and retry.

If it works, please report the issue to the developers of LibXC.
by pouillon
Sun Apr 17, 2016 11:24 am
Forum: Platform specific questions
Topic: Can not pass test with Cuda-Double (While Cuda-Single Can) [SOLVED]
Replies: 1
Views: 2639

Re: Can not pass test with Cuda-Double (While Cuda-Single Ca [SOLVED]

I wouldn't worry too much about GPU issues, because they will bring an interesting speed-up only in specific cases. If your hardware is a bit outdated, MPI and OpenMP will do a pretty good job already.
by pouillon
Wed Apr 13, 2016 2:01 pm
Forum: Configuration
Topic: How to build abinit [SOLVED]
Replies: 1
Views: 2382

Re: How to choose libraries to achieve the fastest speed. [SOLVED]

Achieving the fastest speed will depend a lot on your architecture and on the kind of calculations you perform. There is no generic recipe that would guarantee better performance. And in some situtations, better performance means also less stability. You have to try different combinations. On an Int...
by pouillon
Wed Apr 13, 2016 1:51 pm
Forum: Configuration
Topic: Error occurs when enable fallbacks as well as gpu. [SOLVED]
Replies: 1
Views: 1789

Re: Error occurs when enable fallbacks as well as gpu. [SOLVED]

Simply use the following:

Code: Select all

with_dft_flavor="bigdft+libxc+wannier90"


AtomPAW is not necessary to build nor run Abinit, and you can easily build it separately.