Search found 12 matches

by zeroth
Wed Nov 18, 2020 10:13 am
Forum: Build system
Topic: MPI level = 3 fails
Replies: 1
Views: 1619

MPI level = 3 fails

When trying to use MPI level 3 (--with-mpi-level=3) the build crashes. The reason is quite simple, Look at shared/common/src/11_memory_mpi/m_profiling_abi.F90 There you have: #ifdef HAVE_MPI2 use mpi #endif ... #if defined HAVE_MPI1 include 'mpif.h' #endif but no where do you have HAVE_MPI3. This re...
by zeroth
Sun Dec 06, 2015 9:06 pm
Forum: Configuration
Topic: make test_* abinit already in path [SOLVED]
Replies: 8
Views: 5687

Re: make test_* abinit already in path [SOLVED]

Ok, weird.
Well, until I figure out why, I will close this issue.

Thanks for help.
by zeroth
Wed Dec 02, 2015 9:57 am
Forum: Configuration
Topic: make test_* abinit already in path [SOLVED]
Replies: 8
Views: 5687

Re: make test_* abinit already in path [SOLVED]

Thanks Marc, I called it like this: ../../tests/runtests.py --loglevel=INFO -v -v -n 2 --pedantic atompaw etsf_io libxc wannier90 that should enable all tests right? And call them in correct order? If not I think the test API is slightly confusing My assumption was that it runs them all sequentially...
by zeroth
Tue Dec 01, 2015 8:45 am
Forum: Configuration
Topic: make test_* abinit already in path [SOLVED]
Replies: 8
Views: 5687

Re: make test_* abinit already in path [SOLVED]

While I know that you can download PAWs, I think the intent was to ship it with build system, otherwise a test does not make sense (taking a wrong pseudo will give "erroneous" results)
by zeroth
Mon Nov 30, 2015 9:06 am
Forum: Configuration
Topic: make test_* abinit already in path [SOLVED]
Replies: 8
Views: 5687

Re: make test_* abinit already in path [SOLVED]

1) It is usually not recommanded to have "." in the path since you may have conflict with other search directories. I agree, it was however the only way I could successfully run the tests. 2) You use the old fashion test farm which is not upgraded anymore but migrated to the new test farm...
by zeroth
Sat Nov 28, 2015 12:40 am
Forum: Configuration
Topic: make test_* abinit already in path [SOLVED]
Replies: 8
Views: 5687

make test_* abinit already in path [SOLVED]

Problem, You have abinit in your path PATH=$HOME/bin:./ and abinit in $HOME/bin. Note that the current directory path is after bin. Running make test_* will do these things: cp $(top_builddir)/src/98_main/abinit $(top_srcdir)/tests/built-in/Input/abinit && cd $(top_srcdir)/tests/built-in/Inp...
by zeroth
Fri Apr 04, 2014 11:40 pm
Forum: Configuration
Topic: Possible bug in interface for several files [SOLVED]
Replies: 2
Views: 1680

Re: Possible bug in interface for several files [SOLVED]

Ok. Thanks for the response!
I regard this as closed then... :)

Regards Nick
by zeroth
Fri Apr 04, 2014 11:38 am
Forum: Configuration
Topic: Possible bug in interface for several files [SOLVED]
Replies: 2
Views: 1680

Possible bug in interface for several files [SOLVED]

Dear developers, I am compiling abinit and looking at the output I found a couple of warnings (which I agree with ). Here is an outline of an example code that has a bug (starting from line 573 in 68_dmft/m_hu.F90): subroutine rotatevee_hu(cryst_struc,hu,nspinor,nsppol,pawprtvol,rot_mat,udens_atoms)...
by zeroth
Thu Feb 06, 2014 4:45 pm
Forum: Configuration
Topic: Configure error, and newline operator in preprocessor [SOLVED]
Replies: 7
Views: 4456

Re: Configure error, and newline operator in preprocessor [SOLVED]

Ok, great!

I will go that route then.

Thanks for all the help!
by zeroth
Tue Feb 04, 2014 10:26 am
Forum: Configuration
Topic: Configure error, and newline operator in preprocessor [SOLVED]
Replies: 7
Views: 4456

Re: Configure error, and newline operator in preprocessor [SOLVED]

Here it is: configure:21913: checking whether the Fortran compiler accepts long lines configure:21928: /home/nicpa/phd/code/install/.compile/abinit-7.6.1/build-tmp/config/wrappers/wrap-mpifc -m64 -o conftest -m64 -fPIC -O3 -ftree-vectorize -fexpensive-optimizations -funroll-loops -fprefetch-loop-arr...
by zeroth
Mon Feb 03, 2014 10:06 am
Forum: Configuration
Topic: Configure error, and newline operator in preprocessor [SOLVED]
Replies: 7
Views: 4456

Re: Configure error, and newline operator in preprocessor [SOLVED]

Dear Matteo and Jordan, So it seems like Jordan knows how to fix it? Do you need anymore information then? And yes, the error stems from compiling files in the 62_ctqmc directory, sorry about not saying the directory. It goes for all files which includes the mentioned file in my original post. The e...
by zeroth
Fri Jan 31, 2014 11:08 am
Forum: Configuration
Topic: Configure error, and newline operator in preprocessor [SOLVED]
Replies: 7
Views: 4456

Configure error, and newline operator in preprocessor [SOLVED]

I am currently trying to install Abinit 7.6.1 on my machine. 1. The first thing is a configure error for detecting netcdf. By doing: grep "call nf90" configure in the abinit folder you get this output: ncerr = call nf90_open_par(path, cmode, comm, info, ncid) which clearly is wrong. nf90_o...